Closed Bug 220344 Opened 18 years ago Closed 18 years ago

current tab loses focus when some background tab finishes loading

Categories

(SeaMonkey :: Tabbed Browser, defect)

x86
Linux
defect
Not set
normal

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 124750

People

(Reporter: man, Assigned: jag+mozilla)

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030819
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030819

Just an example: I type www.altavista.com in the address bar, hit enter,
immediately open another tab, open some page there, and, while altavista is
still loading, start to enter something in the form on this second page. But
then, all
of a sudden, the cursor dissappears and anything I write seems to go in vane.
After little studying I found where it really goes - to the altavista's search
form! So, the tab which wasn't open and was loading in background, somehow got
focus from the currently active tab, where I was typing something. It's
obviously a bug.

Reproducible: Always

Steps to Reproduce:
1.Open some page in a tab
2.While it's still loading, open another tab
3.Type something in this another tab

Actual Results:  
Once the background tab finishes loading, the place I type to loses focus

Expected Results:  
Focus shouldn't change on completion of background tab download
altavista.com has:

<body bgcolor="#FFFFFF" text="#000000" onLoad="refocus()">

so this is bug 124750

*** This bug has been marked as a duplicate of 124750 ***
Status: UNCONFIRMED → RESOLVED
Closed: 18 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.