Closed Bug 220394 Opened 19 years ago Closed 19 years ago

After installing DownloadStatusBar, default theme disappears from options

Categories

(Firefox :: Preferences, defect)

defect
Not set
normal

Tracking

()

VERIFIED INVALID

People

(Reporter: zspoelstra, Assigned: bugzilla)

References

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6a) Gecko/20030926 Firebird/0.7+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6a) Gecko/20030926 Firebird/0.7+

The themes pane in the options windows does not show the "default" theme.  The
only theme shown is "modern."  This causes you to not be able to return to the
default theme if you switch themes.

Reproducible: Always

Steps to Reproduce:
1. Tools -> Options
2. Go to Themes pane

Actual Results:  
Only "modern" shows up

Expected Results:  
"default" should be shown and selected
"modern" should not even be available
WFM 20030924 PC/Win2K
in firebird it's "Mozilla Firebird" instead of "default", you could make this
bug "request for enhancment" to change the name to "default".
Right.  It is "Mozilla Firebird" but it is still not present in my 20030926
build of Firebird.  There is only the "modern" theme.
Works for me using Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6a)
Gecko/20030926 Firebird/0.7+

Please try installing into a new directory and creating a new profile, using the
MozillaFirebird.exe -p switch, and report your results here

there is an issue with older profiles from when the MoziilaFirebird theme was
reporting out of date, a clean profile fixes it.  This can also be caused if you
have an older version of Firebird Help installed
Ok.. figued it out.  It is actually an extension that causes this to disappear.
 Upon a fresh install it works fine.  After installing DownloadStatusBar
"Mozilla Firebird" is no longer in the themes list.
Status: UNCONFIRMED → RESOLVED
Closed: 19 years ago
Resolution: --- → INVALID
Summary: Themes option pane does not show "default" theme → After installing DownloadStatusBar, default theme disappears from options
verified invalid.
Status: RESOLVED → VERIFIED
*** Bug 223061 has been marked as a duplicate of this bug. ***
.
Severity: major → normal
OS: Windows 2000 → All
Hardware: PC → All
I tested quite a few extensions on a new profile and I don't think it's a
problem with any particular extension; I have Download Status Bar, Download
Sort, and Stumbleupon installed and none of them caused any problems; on my
installation it was Quickprefs that caused the theme option to disappear. The
"Mozilla Firebird" option disappears from the "Theme" section as soon as the
problematic extension is installed  - not even a restart is needed. Also, I've
noticed quite a depreciation in performance with Quickprefs installed with
Firebird hogging much of the CPU resourses... 
This _IS_ a problem with the extension(s).  I reported this particular problem
to the downloadstatusbar bugzilla and they have since fixed it.  You can read
about what the problem is and how it was fixed here ->
http://mozdev.org/bugs/show_bug.cgi?id=4717
Thanks, Zach, for pointing that out. I think I'll post a bug report in the
Quickprefs pages.
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs,
filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → preferences
You need to log in before you can comment on or make changes to this bug.