Closed Bug 220395 Opened 18 years ago Closed 18 years ago

Help needs better Help and Support Center (welcome_help.html)

Categories

(SeaMonkey :: Help Documentation, defect)

x86
Windows 98
defect
Not set
normal

Tracking

(Not tracked)

VERIFIED FIXED
mozilla1.6beta

People

(Reporter: danielwang, Assigned: rjkeller)

References

()

Details

Attachments

(4 files, 4 obsolete files)

The opening page of Help needs to be rewritten. The page should feature links to
the release note, mozilla community link, and newsgroups (duplicate
www.mozilla.org/start/1.4/support.html).

Keller, you asked where to put info on talkback agent. Perhaps this is a good
place too.
OK. The release notes thing is pretty reasonable since we could use the DTD
file. Newsgroups wouldn't be bad either.

I don't know if I'd like to have talkback content on this page, though. It would
seem kinda strange to have it in the introductory content. We might just keep it
in the glossary after all.
Status: NEW → ASSIGNED
Maybe some stuff from the Mozilla 1.0 start page would be good to add.
I'm actually thinking about sub-catagories under Help and Support Center. We
could use separate pages for Mozilla feedbacks (e.g. crash report, Minh's
wishlist, and our de-facto support forums - MozillaZine forums). Also, I think
this bug should apply to 1.4.2 (I doubt we can make it to 1.4.1)

and btw, we have a new and better 1.4 start page already ;-)
Daniel, per your comment to Bart's email:
MozillaPL Team (http://mozillapl.org) also offers technical support which is
free but right now based on consultants availabity. 
We support our branded versions as well as original Mozilla.org bits. It's
Polish language based service. 
well, actually we can't do the DTD thing. It doesn't seem to work with HTML, so
we're probably not going to get release notes in.
Attached patch Patch - Incomplete (obsolete) — Splinter Review
This is my incomplete patch. I posted it so y'all can see what I'm thinking
about and get some feedback on it.
How about?

[HELP ON THE WEB]            [MOZILLA COMMUNITY]
*Release Notes*: Latest      *MozillaZine*: the oldest
information about known      community site around,
problems or issues with      providng news flashes,
Mozilla.                     polls, and Web forums.

*Troubleshooting*:
asnwers to some of the
most frequently
encountered problems.

*PluginDoc*: up-to-date
information on Mozilla
plug-ins.

[SUPPORT]
mozilla does not provide official support. However,
you can use the following third-party resources to
get your questions answered.

[Technical Support]           [Peer Support]
*DecisionOne*: commercial     *MozillaZine Forums*:
service providing e-mail      Web forums for Mozilla
and phone-in support.         users like you

*MozillaPL*: free community   *User Newsgroups*: user
service based on consultants  newsgroups hosted by
availabity.                   mozilla.org

                              *Realtime Chat*: chat
                              with Mozilla users via IRC.

[USER FEEDBACK]

*Quality Talkback Agent*:
I don't think that the release notes will work without the DTD. I don't like the
thought of having to update the release notes URL in help every milestone.

Also, where does DecisionOne link to? Isn't technical support though DecisionOne
official support from mozilla.org (or going to be)? They said something like
that from MozillaZine.

I don't think I like the Quality Feedback Agent there either. That's for crash
data, it's not really for feedback on the product.

Also, to think about localization, would something like this be easy to
translate? We might end up having different content for different languages. I'm
going to try and see how Netscape does it.
Is there a user newsgroup page?
> Is there a user newsgroup page?
http://www.mozilla.org/start/1.4/support.html , but newsgroups are going to be
moved to a newserver and reorganized (bug 62228)
> [Technical Support]           [Peer Support]
> *DecisionOne*: commercial     *MozillaZine Forums*:
> service providing e-mail      Web forums for Mozilla
> and phone-in support.         users like you

The beta site (http://www.mozilla.org/website-beta/support/) has a nice support
page we could link to. 

> *Troubleshooting*:
> asnwers to some of the
> most frequently
> encountered problems.

Where would this link to?
> The beta site has a nice support page we could link to. 

yes, when it goes live.

>> *Troubleshooting*:
>
> Where would this link to?

www.mozilla.org/start/1.4/faq/troubleshooting.html . It's not clear that the FAQ
contains troubleshooting info. I think we should move it to 1.4/troubleshooting/
because it's a large topic on its own.
Let's wait until the Mozilla 1.6 start page is up before fixing this.
Depends on: start1.6
*** Bug 225663 has been marked as a duplicate of this bug. ***
-> Bart :-)
Assignee: rlk → bart
Status: ASSIGNED → NEW
QA Contact: stolenclover → rlk
Daniel, why'd you reassign this?
Attached patch Patch (obsolete) — Splinter Review
Patch with added stuff. It looks a bit plain now.

bart: may you please supply us with some images that will make this page more
visually appealing?
Attachment #132230 - Attachment is obsolete: true
--> me
Assignee: bart → rlk
QA Contact: rlk → stolenclover
*** Bug 225663 has been marked as a duplicate of this bug. ***
Hi folks,

It's great to see that you guys are working on improving the Help welcome page.
 I do think that the Netscape one is a great reference.  

What's the easiest way to view the page with the patch applied?

Re: art work.  I don't have any.  I just put together a quick (and dirty!) hack
of an icon last night based on what was already on the site.  Dawn,
endico@mozilla.org, however, has postscript files for at least the M icon and
just pushed that to the site - so you can contact her if you'd like the original.

Let me know if there's any other way I can help.  My biggest priority is that we
have at least a text link to Decision One phone support by the time we release
1.6.  

  
Attached patch Complete Patch (obsolete) — Splinter Review
This patch updates all the links to jar.mn and in other docs to the new XHTML
welcome screen, along with the updated layout from the previous patch.
Attachment #135532 - Attachment is obsolete: true
Attached image Screenshot1
> What's the easiest way to view the page with the patch applied?

Here's some screenshots of the page. It's difficult to view the page without
buliding it because of the CSS changes.
Attached image Screenshot2
Attachment #135568 - Flags: review?(neil.parkwaycc.co.uk)
A big move forward for what we currently ship!  

My personal preference would be to consolidate the support info as much as
possible around the /support/index.html page on the web site to improve
manageability.  I'm sure that page could be a lot better than it is now.  I'm
worried that maintaining a number of different help areas (the help menu, the
start page, the web page) will prove hard to maintain over time. 
 
A specific suggestion in this regard: there are currently 3 subsections on
/support/index.html.  Let's add additional ones if necessary and let's then
simply link to the appropriate subsection from the help menu page.  

So in the Support area, instead of Technical Support and Peer Support with the
various subentries, we would feature: Telephone Support | End User Documentation
| Community Support (or any additional subsections that you may wish to add to
the support page on the web site) and an intro sentence for each.  For telephone
support, I suggest "Need help? Affordable telephone support is <link>now
available</link>.

And I suggest that we remove the Help on the Web and Mozilla Community sections
altogether.  If we want those sections, let's put them on the
/support/index.html page as subsections and then link to that.  
> My personal preference would be to consolidate the support info as much as
> possible around the /support/index.html page on the web site to improve
> manageability.  I'm sure that page could be a lot better than it is now.  I'm
> worried that maintaining a number of different help areas (the help menu, the
> start page, the web page) will prove hard to maintain over time. 

Aren't we doing that now, though? We do link to the support page.

> A specific suggestion in this regard: there are currently 3 subsections on
> /support/index.html.  Let's add additional ones if necessary and let's then
> simply link to the appropriate subsection from the help menu page.  

So are you thinking of a format like this:
<h2>Support</h2>
<p><strong>Community Support</strong></p>

or this:

<h2>Support</h2>
<h3>Community Support</h3>
... info and links to community support.


> So in the Support area, instead of Technical Support and Peer Support with the
> various subentries, we would feature: Telephone Support | End User Documentation
> | Community Support (or any additional subsections that you may wish to add to

But we can only have two headings in a section. Are you asking for what I said
above?
Status: NEW → ASSIGNED
+ <p><strong><a
href="http://www.mozilla.org/start/1.0/faq/troubleshooting.html">Troubleshooting</a></strong></p>

should link to start/1.4/troubleshooting

quality feedback agent should link to http://www.mozilla.org/quality/qfa.html
> should link to start/1.4/troubleshooting

Thanks for telling me! I was trying to figure out where to link that too and
couldn't figure out a troubleshooting section in the 1.4 docs.

> quality feedback agent should link to http://www.mozilla.org/quality/qfa.html

OK, I'll put that in the next patch. I'll keep this patch up for another day or
two to obtain feedback.
Attached patch Patch v2 (obsolete) — Splinter Review
Patch with daniel's comments.
Attachment #135568 - Attachment is obsolete: true
Attachment #135568 - Flags: review?(neil.parkwaycc.co.uk)
Comment on attachment 136198 [details] [diff] [review]
Patch v2

Daniel, feel free to review- this if you see a problem.
Attachment #136198 - Flags: review?(neil.parkwaycc.co.uk)
Attached patch Patch v2.1Splinter Review
This patch uses &brandShortName; instead of Mozilla in places where it'd be
appropriate. Forgot it in the last patch, sorry for the spam!
Attachment #136198 - Attachment is obsolete: true
Attachment #136198 - Flags: review?(neil.parkwaycc.co.uk)
Attachment #136200 - Flags: review?(neil.parkwaycc.co.uk)
Does recent nightlies have Quality Feedback Agent? If not we should comment it
out for now.

Keller, you might want to update chrome://global-region/locale/region.dtd too.
Also, you have two links to www.mozilla.org and one to mozilla.org, make up your
mind please ;-) (btw, I prefer www.)
> Keller, you might want to update chrome://global-region/locale/region.dtd too.

why? What needs to be changed? everything looks OK to me.

> Also, you have two links to www.mozilla.org and one to mozilla.org, make up your
> mind please ;-) (btw, I prefer www.)

heh. aren't we being a bit picky, now? the "www" is too many letters to type :).
Personally I don't think it's worth spamming people by making a new patch and
attaching it.
Comment on attachment 136200 [details] [diff] [review]
Patch v2.1

>Index: resources/locale/en-US/help_help.html
You should patch help_help.xhtml too.

>+      <p><strong>Realtime Chat</strong></p>
A link irc://moznet/mozillazine would be nice here.
Attachment #136200 - Flags: review?(neil.parkwaycc.co.uk) → review+
--> Browser: Help

It's not really the appropriate place, but we can set approval1.6b flags 
there :)
Component: User → Help
Product: Documentation → Browser
Target Milestone: --- → mozilla1.6beta
Version: unspecified → Trunk
Comment on attachment 136200 [details] [diff] [review]
Patch v2.1


> You should patch help_help.xhtml too.

hmm. not sure how that got changed. when I check this in, I'll change it to
.xhtml.

>+      <p><strong>Realtime Chat</strong></p>
A link irc://moznet/mozillazine would be nice here.

I was thinking of this, but ChatZilla might not be installed on that users
machine. Maybe having a link below mentioning getting help in IRC? Not sure if
this would be appropriate place for that, either, since it looks like we're
trying to contain information about mozilla support, and IRC doesn't appear to
be an official place for support (at least I don't think so, could be wrong).
Attachment #136200 - Flags: approval1.6b?
Comment on attachment 136200 [details] [diff] [review]
Patch v2.1

a=asa (on behalf of drivers) for checkin to 1.6b.
Attachment #136200 - Flags: approval1.6b? → approval1.6b+
Fix checked in. Any other issues/enhancements should go in another bug.
Status: ASSIGNED → RESOLVED
Closed: 18 years ago
Resolution: --- → FIXED
v

many issues remain
Status: RESOLVED → VERIFIED
> MozillaPL Team (http://mozillapl.org) also offers technical support which is
> free but right now based on consultants availabity. 
> We support our branded versions as well as original Mozilla.org bits. It's
> Polish language based service. 

P. Bartecki, can you give a specific page to this support thing?

rlk, Help and m.o/support/ should link to www.mozilla-europe.org/en/services/ ,
which offers enterprise support. (I know, I should file a new bug, but feeling
lazy...)
Daniel: please file a new bug, and while you are at it, explain what on earth
you are talking about :-)

Thanks,

Gerv
> Daniel: please file a new bug, and while you are at it, explain what on earth
> you are talking about :-)

sorry, bug 250809
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.