If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

browser crash when opening a tab set then immediately clicking on first page, clicking close other tabs

RESOLVED WORKSFORME

Status

SeaMonkey
Tabbed Browser
--
critical
RESOLVED WORKSFORME
14 years ago
9 years ago

People

(Reporter: not given, Assigned: jag (Peter Annema))

Tracking

({crash})

Trunk
x86
Windows XP
crash

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; Q312461; YComp 5.0.2.6; .NET CLR 1.0.3705)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030624

When you have a set of tabs open, and (mistakenly or purposefully) open 
another set, then right-click on the first window tab and select "close other 
tabs".  Brower crashes.

i suspected that mozilla was still waiting for the data to come back from the 
other, newly-requested tabs.   But since the windows were closed, Mozilla was 
just confused and crashed.

Reproducible: Always

Steps to Reproduce:
1. open a tab set.  Wait for them to load
2. open a second tab set.  Curse b/c you didn't mean to open another tab set...
3. immediately right-click on the first, original tab (first window).
4. immediately select "close other tabs"
5. hourglass will persist; mozilla crashes
6. in addition, any new tabsets added during that session will be lost -- why 
wouldn't those be written out dynamically rather than when browser is closed.

Actual Results:  
crash

Expected Results:  
not crashed (terminated waiting-for-data from requested pages state)

I am a convert.

Updated

14 years ago
Severity: normal → critical
Keywords: crash

Comment 1

14 years ago
Your Mozilla version is rather old (from June 2003). Could you try if you still
see this bug with Mozilla 1.5rc2 or a Nightly?

Concerning 6.: There now is a preference whether opening a new tab group should
clobber the existing tabs.
(Reporter)

Comment 2

14 years ago
Appears to be a non-issue with 1.5RC2.  Thanks for the nudge to upgrade.  Got 
it to crash only once with 1.5RC2, when really, really trying to *make* it 
crash.  Note: the "replace existing tabs" setting, which is the default, makes 
it impossible to duplicate this error.  Thus, I think the user base is safe 
from this problem.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.