Add autocomplete (history) to textbox in "Find in This Page" dialog

VERIFIED WONTFIX

Status

()

--
enhancement
VERIFIED WONTFIX
15 years ago
15 years ago

People

(Reporter: klassphere, Assigned: bugzilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6a) Gecko/20030926 Firebird/0.7+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6a) Gecko/20030926 Firebird/0.7+

It's nice if "Find what" box in "Find in This Page" dialog is a combo box and
remembers history of searched words.

Reproducible: Always

Steps to Reproduce:

Updated

15 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
if you really want search history of find in this page, use the search bar instead.

This isn't feature parity with anything I've ever seen in a browser, and it
would definitely bloat the UI

-> WONTFIX
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 2

15 years ago
Comment #1:
well I admit I didn't know there is already such feature (one click on that
Google icon in search bar and you'll get "find in this page") and I don't think
it's the most natural and intuitive UI :p Who knows there's such feature hidden
in it? And there's no match case/wrap/up/down in that search bar.
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---

Updated

15 years ago
Summary: Add history to "Find what" box in "Find in This Page" dialog → Add autocomplete (history) to textbox in "Find in This Page" dialog
making the search bar "find in this page" more discoverable is why the
dropmarker was added, however that isn't relevant to this bug and isn't cause to
reopen it.
Status: REOPENED → RESOLVED
Last Resolved: 15 years ago15 years ago
QA Contact: mconnor
Resolution: --- → WONTFIX

Comment 4

15 years ago
*** Bug 230207 has been marked as a duplicate of this bug. ***

Comment 5

15 years ago
Mike, for reference in response to c#1, Konqueror does in fact do this since
Konq uses the KDE-wide search function. I can't say it bloats the UI any since
it is just a drop down arrow. That said, I don't think there's too much use for
this type of thing either.

v. 
Status: RESOLVED → VERIFIED

Comment 6

15 years ago
"This isn't feature parity with anything I've ever seen in a browser, and it
would definitely bloat the UI"

Um, it would definitely NOT bloat the UI since it wouldn't even appear until you
started to type something in the find box. :)
not visually, but perf-wise it would, which is what I intended to say here
You need to log in before you can comment on or make changes to this bug.