Unable to click on content of page with two DOCTYPE/HTML/HEAD/BODY tags

VERIFIED DUPLICATE of bug 102695

Status

()

defect
VERIFIED DUPLICATE of bug 102695
16 years ago
16 years ago

People

(Reporter: dagobart, Assigned: harishd)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

()

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6a) Gecko/20030926 Firebird/0.7+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6a) Gecko/20030926 Firebird/0.7+

The blue underlined links - which are events - can't be clicked to see. With IE
there is no problem.

Reproducible: Always

Steps to Reproduce:
1.See page http://www.patrouille-suisse.ch/eventcalendar/index.php
2.Try to click on a event
3.Not possible

Actual Results:  
No response

Expected Results:  
A click should bring a the page with this event in the calendar.
The links do not work because the HTML is broken.  Viewing source reveals the
page has:

DOCTYPE
<HTML>
<HEAD></HEAD>
<BODY>
DOCTYPE
<HTML>
<HEAD></HEAD>
<BODY></BODY>
</BODY>
</HTML>
</HTML>

When I just deleted the duplicate DOCTYPE, HTML, HEAD, BODY then the page worked.

I would suggest you write to the site and ask them to straighten out their code.

I'm going to try moving this to Browser/Parser (the same thing happens in
Mozilla) to see if we should be doing anything better/more in the way of
handling this example of broken code.  Otherwise, this should be moved over to
Tech Evangelism.
Assignee: blake → harishd
Status: UNCONFIRMED → NEW
Component: General → Parser
Ever confirmed: true
Product: Firebird → Browser
Summary: Underlined links in page can't be clicked → Unable to click on content of page with two DOCTYPE/HTML/HEAD/BODY tags
Version: unspecified → Trunk
Actaully, the parser is not at fault here.  The "second" (first, actually) body
has a div that's positined over all the content.  This div gets the click
events, so the content below it never sees them.

*** This bug has been marked as a duplicate of 102695 ***
Status: NEW → RESOLVED
Closed: 16 years ago
Resolution: --- → DUPLICATE
Thanks for looking into this. Sorry about that I didn't check myself at first
the HTML-code of this strange page. BTW also Opera 7.20 can't read the links on
this page. I sent a EMail to the webmaster of this site. Thanks again.
verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.