[patch]The title tag won't display "Jeff Ziel"

RESOLVED FIXED

Status

RESOLVED FIXED
15 years ago
15 years ago

People

(Reporter: fubar, Assigned: mikepinkerton)

Tracking

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.5b) Gecko/20030917 Camino/0.7+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.5b) Gecko/20030917 Camino/0.7+

All other titles appear as expected, except title="Jeff Ziel" - I created a test
page that shows "Jeff Z" and "Jeff Zi" work, but "Jeff Zie" and "Jeff Ziel" do not.

I also posted several test cases on the same page. The page validates as 4.01.

Reproducible: Always

Steps to Reproduce:
1.<a title="Jeff Ziel">Jeff Ziel</a>
2.
3.

Actual Results:  
A 'tooltip' or mouseover display appears showing only "Jeff " (note the space)

Expected Results:  
Displayed "Jeff Ziel" in a 'tooltip' or mouseover display.

This bug has been in Camino since at least Decemeber. This bug does not appear
in any IE version for MacOS X, nor has it been in Mozila 1.0 or 1.5b.

Comment 1

15 years ago
Possible dup of bug 215513
(Reporter)

Comment 2

15 years ago
Added the following to the test page:

<a title="Stephen P. Jobs">Stephen P. Jobs</a>
<a title="United States of America">United States of America</a>
<a title="The State of Hockey">The State of Hockey</a>

All display properly (without wrapping) and contain several more charactors than:

<a title="Jeff Ziel">Jeff Ziel</a>
Created attachment 133557 [details] [diff] [review]
a fix

fixes the problem and simplifies the code, all in one fell swoop.
Confirming based the fact that david wrote a patch.
Changing summary to refrlect the fact that a patch is present.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: The title tag won't display "Jeff Ziel" → [patch]The title tag won't display "Jeff Ziel"
(Assignee)

Comment 5

15 years ago
-    mTextField = [[[NSTextField alloc] initWithFrame: NSMakeRect(0.0,
kBorderPadding, 200.0, 200 - 2*kBorderPadding)] autorelease];
+    mTextField = [[NSTextField alloc] initWithFrame: NSMakeRect(0.0,
kBorderPadding, 200.0, 200 - 2*kBorderPadding)];

why bother making this change? it seem gratuitous.

otherwise the patch looks good to me. Get some testing, and we'll push it.
*** Bug 215513 has been marked as a duplicate of this bug. ***
Comment on attachment 133557 [details] [diff] [review]
a fix

tested work fine on both bugs. I just whish the #define in the .mm file would
be in the .h file , but this comes from the previous patch
Attachment #133557 - Flags: review? → review+
(Assignee)

Comment 8

15 years ago
landed, thanks dave.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.