Preferences controlling wrap-to-window ignored, always wraps (Message Display, Compose)

RESOLVED DUPLICATE of bug 116688

Status

RESOLVED DUPLICATE of bug 116688
15 years ago
10 years ago

People

(Reporter: man, Assigned: sspitzer)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030819
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030819

If I set Preferences | Mail&News | Composition | Wrap plain text msgs at N
characters to 0, messages shouldn't be wrapped (If I'm not mistaken). But once
text reaches the editing widget's right edge, it wraps to the next line. I think
that, instead of this, horizontal scrollbar should appear and stuff should
scroll to the right. There should be no-wrap mode!

Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Comment 1

15 years ago
There are two different wraps that are coming in to play here:  When you set 
that preference, you are saying that the line length on outgoing mail should not 
be restricted.  And in fact, if you set the preference to 0 and then send a 
message to yourself with a long line of text, on reading that message, you will 
see that there are no "hard line breaks" -- as you resize the message, the text 
will reflow to the window edge, until the window is wider than the line that was 
sent.

However, Mozilla (almost always) wraps text in a message or compose window so 
that you can see the whole thing without scrolling.  Sometimes, it leads to 
staggered looking text like this:

This text was written with a wrap line of
fifty
characters, but is being viewed in a window 
that's
only forty characters wide.

(The above "message" would have been written without "format=flowed" to show up 
that way; this feature is described by RFC 2046 and was designed to avoid 
exactly this problem.)

The one case where I regularly see horizontal scrollbar in a message window is 
in a reply with quoted text, where the original message was written with no 
wrap, and without format=flowed.  In that case, the quoted lines are shown in 
the compose window at their full original length, extending beyond the window 
edge as necessary.  On receipt, viewing that same message shows the quoted text 
reflowed to the window edge again.

None of this is to say that this bug is invalid: I can certainly see how 
disabling the wrap-to-window feature could get in the way.  There is a 
preference, mail.wrap_long_lines, but I don't see any difference in behavior in 
either message viewing or composition when that is set false.

Comment 2

15 years ago
There are two prefs:
  mail.wrap_long_lines
  mail.compose.wrap_to_window_width

The first one is accessible via Preferences. The 2nd is hidden. To access the
hidden pref, type "about:config" in the location bar.

Please resolve this bug as INVALID if setting the pref works.

Comment 3

15 years ago
Thanks for pointing that out, Daniel... but:

The default value for  mail.compose.wrap_to_window_length  is false; and I see 
wrapping of the text during composition regardless of the setting of this 
preference.

I notice (*finally*  :)  that about:config has a 'filter' field at the top; 
entering "wrap" into that field shows a half-dozen wrap-related preferences.  
As far as I can tell, three of these do not work as expected; in fact, changing 
any of them has no apparent effect at all:

 mail.compose.wrap_to_window_length    default: false
 mail.wrap_long_lines                  default: true
 news.wrap_long_lines                  default: true

The first of these has a setting in the preference window:
  "Wrap text to fit window width" in  Mail&Newsgroups|Message Display

I'm updating the summary to indicate this problem; Jack Angel, I hope that's OK 
with you.

view_source.wrap_long_lines *does* work as expected in the View Source window.

Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5) Gecko/20030916
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6a) Gecko/20030923
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: plain text messages wrap even if wrapping is disabled (set to 0) → Preferences controlling wrap-to-window ignored, always wraps (Message Display, Compose)

Comment 4

15 years ago
Updating platform/OS.
OS: Linux → All
Hardware: PC → All
(Reporter)

Comment 5

15 years ago
Setting Preferences|Mail&News|Message Display|Wrap plain text msgs to false did
some change - the scrollbar had appeared (the behaviour I was looking for). Is
this bug now invalid or someone thinks there is more?

Comment 6

15 years ago
Jack Angel: by setting that preference, you got the scrollbar on your compose 
window?  What is your setting for the following?  (Find these by entering
 about:config  in your browser's location bar.)
   mail.compose.wrap_to_window_width
   mailnews.display.disable_format_flowed_support

I'm not getting a horizontal scrollbar in either the compose or message-view 
windows, no matter what I try.
(Reporter)

Comment 7

15 years ago
yes
mail.compose.wrap_to_window_width = false
mailnews.display.disable_format_flowed_support = false
(Reporter)

Comment 8

15 years ago
Do you have scrollbar with these options, Mike?

Comment 9

15 years ago
No, I'm not getting a horizontal scrollbar for either the compose or message 
windows.  And I've found a much earlier report of the same problem, which I 
should have found before.

*** This bug has been marked as a duplicate of 116688 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.