Trying to print with mozilla 1.4 do nothing

RESOLVED INVALID

Status

()

--
critical
RESOLVED INVALID
15 years ago
15 years ago

People

(Reporter: gmourani, Unassigned)

Tracking

1.4 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030917 Epiphany/1.0
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030917 Epiphany/1.0

Every application that provide printing capability with Gnome 2.4.0 work fine
with my printer. The only application that it not able to print something is
Mozilla 1.4. The print icon is available and I'm capable to edit it and change
option if I want but when come time to print the page, then nothing happen and
my lpq command report nothing in queue. It look like Mozilla send the page to
queue and stop here.

Again every other applications work correctly with my printer and I'm able to
print anything I want with Gnumeric, Abiword, Gedit, Glable, Gimp, Dia, etc..
and ONLY Mozilla and Epiphany which depend on Mozilla for printing capability is
not able to print.

Here is my compile option used to compile Mozilla.
%configure --with-system-jpeg \
        --with-system-zlib \
        --with-system-png \
        --without-system-mng \
        --enable-default-toolkit=gtk2 \
        --disable-ldap \
        --disable-composer \
        --disable-jsd \
        --disable-freetype2 \
        --disable-xprint \
        --enable-xft \
        --enable-crypto \
        --disable-accessibility \
        --disable-tests \
        --disable-debug \
        --disable-pedantic \
        --enable-optimize="$RPM_OPT_FLAGS -fomit-frame-pointer
-fno-strength-reduce -fno-strict-aliasing" \
        --disable-debug-modules \
        --disable-debugger-info-modules \
        --disable-dtd-debug \
        --disable-xpinstall \
        --enable-reorder \
        --enable-strip \
        --enable-reflow-perf \
        --enable-perf-metrics \
        --enable-nspr-autoconf \
        --without-system-nspr \
        --enable-necko-small-buffers \
        --enable-default-mozilla-five-home=%{_libdir}/mozilla-%{version}

Do you know what is causing this and how to fix it?

Reproducible: Always

Steps to Reproduce:
1. Open Mozilla
2. Go -> File | Print | Print
3.

Actual Results:  
Nothing
Nothing to do with web services.

Does this work with a normal mozilla.org nightly build?  Does it work without
the XFT option?
Assignee: harishd → printing
Component: Web Services → Printing
(Reporter)

Comment 2

15 years ago
> Does this work with a normal mozilla.org nightly build?
I don't no, I only do it on stable 1.4.

> Does it work without the XFT option?
No, with or without XFT option, it doesn't work.
Not a trunk bug, then.
Version: Trunk → 1.4 Branch

Comment 4

15 years ago
Gerhard, what kind of printer do you have? Does it support postscript on its
own, or is that being handled by your print-queuing software?

What is the actual print command you're using? Pick File->Print..., then click
the "Properties" button next to "Printer:". The print command will be listed in
the printer properties window.
(Reporter)

Comment 5

15 years ago
Ok, I've found the problem. It look like Mozilla need urw-fonts package to be
installed on Linux and the fonts directory to be located under
/usr/share/ghostscript/fonts for Mozilla to work and print. Usually, urw-fonts
package as provided by many Linux distro doens't install under
/usr/share/ghostscipt/fonts directory but under /usr/share/fonts/ directory.

Gehrard,
Hmm..  we shouldn't be calling ghostscript ourselves....

Comment 7

15 years ago
Gerhard, mozilla doesn't directly call ghostscript or reference any of
ghostscript's fonts. Mozilla just generates postscript and submits it to the
system's printing software. I think the most likely explanation is that your
system's printing software uses ghostscript to render postscript print jobs for
your printer.

In any event, I'm resolving this since you indicate you've fixed the problem.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.