Browser hanging on printing to a file

RESOLVED WORKSFORME

Status

()

Core
Printing: Output
--
critical
RESOLVED WORKSFORME
14 years ago
14 years ago

People

(Reporter: Daniel de Rauglaudre, Unassigned)

Tracking

({hang})

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20030925
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20030925

When printing that page, using "Print" in "File" menu, with "Print To" either with
"Printer" or "File" (PostScript/default) selected, the browser displays a window
telling that it prepares the printing and blocks. If "File" was selected, the
"printed" file seems had to be stopped in a middle of a line.

Reproducible: Always

Steps to Reproduce:
1.open URL http://us.imdb.com/name/nm0973412/
2.select "File" / "Print"
3.on "Print To", click on "File" then "Print" at end

Actual Results:  
The browser blocks. No more X events are taken into account.

Comment 1

14 years ago
WFM, Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20030916
Summary: Browser blocks → Browser hanging on printing to a file

Comment 2

14 years ago
WFM Linux i686 gcc-2.95.3 compiled build 2003082822 (aka 1.5b). 
Printout is fast and perfect.

Comment 3

14 years ago
WFM w2k 20030925

Updated

14 years ago
Severity: normal → critical
Keywords: hang
(Reporter)

Comment 4

14 years ago
This bug happens (for me) when the selected paper size is A4

Steps to Reproduce:
1.open URL http://us.imdb.com/name/nm0973412/
2.select "File" / "Print"
3.on "Print To", click on "File"
4.click on "Properties"
5.on "Paper Size", select "A4" and click "Ok"
6.then click "Print"

I get a small window telling me:
   Title Laetitia Lefebvre
   Progress: Preparing...

and nothing else happens; the browser windows remain but the browser not treat
any more events.
(Reporter)

Comment 5

14 years ago
Can somebody confirm that when he prints that page with the selected paper size
set to A4, it hangs up? When I do it with the paper size "letter" (which is the
default), it works. The problem happens only when the paper size is A4. Thanks.
(Reporter)

Comment 6

14 years ago
It works when the selected paper size is "Letter" (the default).
I have that problem when the selected paper size is "A4"
Can you confirm that it works when you try with the selected paper set to A4?
Thank you.

Comment 7

14 years ago
Works for me, nightly build 20031101 on Mandrake linux 9.0. I set the paper size
to A4 and printed to a file. Mozilla printed the document, and the result looked
reasonable in ghostview.

Daniel, could you try this with mozilla 1.6a and see if you can reproduce this
problem?
(Reporter)

Comment 8

14 years ago
I checked another time with the same version of Mozilla (1.5rc2) where I had
this problem and now, it works! Mystery of computers... Perhaps there were
something in the advertisings which can change from time to time and even at
each click, or can be different according to possible cookies or personal
language configuration...

Sorry for the disturbing and thank you for having tested again.

Comment 9

14 years ago
-> WFM
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.