right-click, empty trash makes the entire trash folder disappear in the left folders pane

RESOLVED DUPLICATE of bug 79956

Status

SeaMonkey
MailNews: Message Display
RESOLVED DUPLICATE of bug 79956
15 years ago
13 years ago

People

(Reporter: saad chinoy, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

({perf})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030624
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030624

in my case i'm using the set of folders created in an older version of mozilla
version 1.3
all the mail folders display as they should, however when i empty the trash
folder    from the right-click menu, then entire folder disappears from the list. 
Even when you right click on a message and 'move-to' or 'copy-to' list of
folders is missing the 'trash' folder

this also causes the 'delete message' function to not work anymore. i mean any
messages i try to delete after this do not get delted. 
all three ways of deletion (select message and click the delete button, select
and right click menu-delete, or select and press the delete key) dont work.

restarting the browser brings back the trash folder. 

Reproducible: Always

Steps to Reproduce:
1.point the Mail & newsgroup account settings LOCAL folders to point to folders
created by older version (1.3) mozilla
2.right-click on trash folder, empty trash
3.try to delete any message from any folder

Actual Results:  
the 'Trash' folder disappears, with all the trash.
no other message can be delted. 
all other functions are cool. 


Expected Results:  
the messages in the trash folder should go away, leaving the trash folder intact.
(Reporter)

Comment 1

15 years ago
and, oh. when I do an 'empty-trash' from the right click on folder menu, the
messages remain but the folder disappears. when i restart the browser, the trash
folder is back, with the messages in the trash still there.

the only way for me to empty the trash is to select-all messages in the folder
and press 'delete'.
Keywords: mail1, perf

Comment 2

15 years ago
WFM W2k 20030925

Comment 3

15 years ago
WFM Linux i686 gcc-2.95.3 compiled build 2003082822 (aka 1.5b).

Comment 4

15 years ago
For what it's worth, I am seeing exactly the same troublesome Trash folder
behavior with Frederic Bezies's unofficial 2003111014 win32 build available at
http://frederic.bezies.free.fr/weblog/mozilla/

I have not seen this problem with with the last official win32 nightly
(20031028), nor do I remember seeing this with Frederic's unofficial 20031108
win32 build.

I am using win98se.

Comment 5

15 years ago
I just tested this bug with Frederic Bezies's unofficial 2003111109 win32 build
(because still no official win32 builds since 20031028), and everything is
working as expected again.

Must have been a problem specific to that build.

Sorry for the spam.

Comment 6

15 years ago

*** This bug has been marked as a duplicate of 9956 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 7

15 years ago
*** This bug has been marked as a duplicate of 79956 ***

*** This bug has been marked as a duplicate of 79956 ***

Comment 8

15 years ago
oops
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 9

15 years ago
what a mess

*** This bug has been marked as a duplicate of 79956 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago15 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.