Using selected Calendar File as default for new items

RESOLVED DUPLICATE of bug 246740

Status

Calendar
Sunbird Only
--
enhancement
RESOLVED DUPLICATE of bug 246740
15 years ago
12 years ago

People

(Reporter: Matija Polajnar, Assigned: Matthew (lilmatt) Willis)

Tracking

Details

Attachments

(1 obsolete attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5) Gecko/20030925
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5) Gecko/20030925

I use multiple calendars for purpose of "grouping" items, so I can, for example,
exclude some items by unchecking one calendar. In my example, I have a calendar
file for school timetable, and another one for exams.

  1. When I add a new event (or task), I'd like that default calendar file would
be the calendar file selected in "Calendars" tab.
  2. The same for importing -- I import my timetable and I'd like to select
which file Mozilla should import to. I cannot select "Timetable" file for 68 events.

Reproducible: Always

Steps to Reproduce:
1. Create multiple (at least two) calendar files (in "Calendars" tab).
2. Select second calendar.
3. Add a new item (or import new items).
Actual Results:  
Items are (by default) put into the first calendar file listed.

Expected Results:  
I expect Mozilla to put them (by default) into the Calendar File selected in the
"Calendars" tab.
(Assignee)

Comment 1

14 years ago
The lack of this feature has bugged me in the past as well.

status -> NEW

Taking
Assignee: mostafah → mattwillis
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 2

14 years ago
Created attachment 163058 [details] [diff] [review]
rev0 - trunk - patch moves "check if a server is selected" code outside the "silent/not silent" if
(Assignee)

Updated

14 years ago
Attachment #163058 - Flags: first-review?(mostafah)

Comment 3

14 years ago
Point 1 (new event) works for me: if a calendar is selected it uses that,
otherwise it uses the first calendar
Point 2 (import) is Bug 246740, which has a patch awaiting approval and checkin
from mostafah.

Suggest mark this bug dup of bug 246740, and mark this patch obsolete.
(Assignee)

Comment 4

14 years ago
Comment on attachment 163058 [details] [diff] [review]
rev0 - trunk - patch moves "check if a server is selected" code outside the "silent/not silent" if

Patch obsoleted by duplicate bug
Attachment #163058 - Attachment is obsolete: true
Attachment #163058 - Flags: first-review?(mostafah)

Comment 5

14 years ago

*** This bug has been marked as a duplicate of 246740 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
The bugspam monkeys have been set free and are feeding on Calendar :: Sunbird Only. Be afraid for your sanity!
QA Contact: gurganbl → sunbird
You need to log in before you can comment on or make changes to this bug.