Save as dialog doesn't append .htm extension to dynamic page names

RESOLVED DUPLICATE of bug 221899

Status

()

RESOLVED DUPLICATE of bug 221899
15 years ago
13 years ago

People

(Reporter: mdalco, Assigned: bugzilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20030925 Firebird/0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20030925 Firebird/0.7

 when I use the File->Save as... feature of Mozilla Firebird 0.7RC with a
dynamic generated page, Firebird doesn't append the .htm estension to the
original page name.

You can try with this bugzilla page: hit Ctrl+S, FB will ask for saving
viewtopic.php file. But you aren't saving a cgi file: you are saving only a
rendered html!
This cause a broken behavior in Windows Explorer: double clicking on the saved
page starts another associated program and not the default browser!
It is a critical bug for unexperienced users!

Reproducible: Always

Steps to Reproduce:
1. Visit a dynamic generated page (.php, .cgi, .pl ...)
2. Go to menu File -> Save as...
3. The file name proposed has not the .html extension
Actual Results:  
You cannot open the file saved with double click in Windows Explorer.

Expected Results:  
The old behaviour: It should add the .html extension to the dynamic page filenames.

Comment 1

15 years ago
In IE, when a page saved with "Web Page, HTML only", this
URL(http://bugzilla.mozilla.org/show_bug.cgi?id=220680) is saved to "Bug 220680
- Save as dialog doesn't append _htm extension to dynamic page names.htm" and
the original file name "show_bug.cgi" is totally lost. I guess this bug may be
WONTFIX, but if it's not, "show_bug.cgi.html" would be better for the name of
the saved file, hopefully with check box to turn off .html appending.

Comment 2

15 years ago

*** This bug has been marked as a duplicate of 221899 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
*** Bug 348324 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.