Closed Bug 220718 Opened 17 years ago Closed 16 years ago

mousewheel scrolls innerHTML when it should not

Categories

(Core :: CSS Parsing and Computation, defect)

x86
Windows 2000
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 259615

People

(Reporter: steve, Assigned: dbaron)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6a) Gecko/20030929 Firebird/0.7+ (aebrahim)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6a) Gecko/20030929 Firebird/0.7+ (aebrahim)

Win2ksp4. When using DThread mode on http://www.shacknews.com/latestchatty.x and
collapsing a thread, the mouse-wheel should always scroll the *whole page* up
and down. However, when using the mouse-wheel over a *collapsed* thread, the
mousewheel scrolls the text *inside* the collapsed thread, rather than the whole
webpage.

IE does not behave like this.
FB 0.6.1 did not behave like this.

Reproducible: Always

Steps to Reproduce:
1. Go to http://www.shacknews.com/latestchatty.x
2. Using the pulldown menu, set mode to "DThread"
3. Find a post that has 4 or 5 lines of text in it, and collapse the thread
(using the [+-] icon on the left hand side of the post)
4. Hover the mouse over the area of the collapsed thread and roll the
mouse-wheel up and down to scroll the page up and down.
Actual Results:  
The text *inside* the collapsed thread is scrolled up and down with the mouse-wheel

Expected Results:  
The text inside the collapsed thread should *not* be scrolled. The whole page
should be scrolled as per usual. The collapsed thread should show the first line
of the post only; you should not be able to scroll through the collapsed
thread's text.
*** Bug 220719 has been marked as a duplicate of this bug. ***
-> style system, dbaron (because he fixed bug 69355).

If this is just the opposite of bug 69355, it might be wontfix.
Assignee: blake → dbaron
Component: General → Style System
Product: Firebird → Browser
Version: unspecified → Trunk
*** Bug 240270 has been marked as a duplicate of this bug. ***
We probably shouldn't scroll scrollframes with 'overflow: hidden'.
(In reply to comment #4)
> We probably shouldn't scroll scrollframes with 'overflow: hidden'.

I thought CSS was just for styling?
I'd have found this if it had had a better title.

*** This bug has been marked as a duplicate of 259615 ***
Status: UNCONFIRMED → RESOLVED
Closed: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.