PDF file does not load; Adobe Reader error flag; after 'OK', error message in task bar

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
15 years ago
2 years ago

People

(Reporter: raych, Assigned: peterlubczynski-bugs)

Tracking

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.5b) Gecko/20030827
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.5b) Gecko/20030827

Instead of this PDF file loading, an error window headed with "Adobe Reader"
says "File does not begin with '%PDF-'."  After clicking 'OK' in that window,
the message "An error has occurred while trying to use this document," appears
at the bottom of the Moz browser.

Reproducible: Always

Steps to Reproduce:
1. Try to access the page of the above URL by any means.
2. Observe what is described above under "Details".
3.

Actual Results:  
See "Details" above.

Expected Results:  
Loaded and displayed the page of this URL.

This page displays properly in both Netscape 4.8 and IE 6.0, without any error
flags.

Comment 1

15 years ago
WFM 2003092604/trunk/W2K using Adobe Acrobat Plug-In Version 6.00 for Netscape
Summary: PDF file does not load; Adobe Reader error flag; after 'OK', error message in task bar. → PDF file does not load; Adobe Reader error flag; after 'OK', error message in task bar

Comment 2

15 years ago
WFM Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.6a) Gecko/20030925
    Adobe Acrobat Plug-In Version 5.10 for Netscape
(Reporter)

Comment 3

15 years ago
Does anybody understand what "File does not begin with '%PDF-'." means?  Most
PDF files now respond this way at the end of their download time, with nothing
at all having shown up in the normal browser window; yet these files show up
properly with Netscape 4.8 (using external AcroRead 6.0) and IE 6.0.  (The Moz
AcroRead 6.0 plugin shows as enabled.)

Ray
(Reporter)

Comment 4

15 years ago
How about someone else trying Plug-In Version 6.00 in Moz 1.5b in Win98SE?

(I removed this plugin and ran the AcroRead repair wizard to put a new copy back
in, but it didn't change anything.)

Ray
(Reporter)

Comment 5

15 years ago
Well, I finally got Moz to display PDF files internally with its plugin for that
purpose -- sort of.  After clearing Moz's cache, I was able to display PDF files
internal to Moz -- after I cleared its cache.  I think the only problem is that,
for some reason, Moz needs its cache dumped even after only one fairly long PDF
file.  Netscape never needs that, but of course, it uses AcroRead externally. 
Also of note is that Moz, for me, is doing this internal PDF displaying with
AcroRead still set for not displaying in my browser, while Moz is set to get PDF
files in an external helper.  What's with that?  I think you guys do all kinds
of unkosher things in Moz and then patch things up to make them work. .
.sometimes.  I do admit that lack of memory often causes me problems in '98SE,
though I have 512 MB of actual RAM.  I don't know if there's any different sort
of way to set up the use of memory that would ameliorate this problem.  I wish
you guys had kept much more of Moz like Netscape 4.x.
(Reporter)

Comment 6

15 years ago
The status of this with me is that once in a long while, for reasons unknown,
Moz 1.5 with AcroRead 6.0 (set for browser-internal) and its plugin will
internally display correctly a PDF file from the Web.  The rest of the time, it
gives the error message which includes '%pdf-'.  It always correctly displays
PDF files from my HD.

After putting the Acro plugin into Netscape 4.8, that browser always (for files
I've tried) displays PDF files internally, from either my HD or the Web, correctly.
(Reporter)

Comment 7

15 years ago
Although you people apparently don't care whether Moz does PDF files with the
AcroRead plugin 6.0 in Win98SE, but maybe your curiosity could be piqued as to
why these URLs work using such:

http://dev.pacadvantage.org:5020/about_health_plans/Directories/2002/Oct_2002_Delta_PPO_Region_3.pdf

http://dev.pacadvantage.org:5020/about_health_plans/Directories/2002/Oct_2002_Delta_FFS_Region_3.pdf

, while these don't:

http://www.busenbark.org/hr/NOV%2001-PPO%20AREA%20DIRECTORY.pdf

http://www.ilawyer.com/bansdc/production/member_services/north_county_lawyer/pdf/jan01nws.pdf

http://www.sgsd.k12.wi.us/central/Employee%20Information/dental/Dental%20Directory%202-02.pdf

; and this one:

http://www.dental.umaryland.edu/alumni/pubs/spring2003/alumni.pdf

gives:

-----------

Error #503
Service Unavailable

BoostWeb BW4.2.21.0 Apr 24 2003 at compression04.oak.mdsg-pacwest.com 

-----------

Ray
(Assignee)

Comment 8

15 years ago
Please attach the HTTP headers that are produced with these URLs. You can have
the headers dumped to a file if you clear your cache and run with these
environment variables:
NSPR_LOG_MODULES=nsHTTP:5
NSPR_LOG_FILE=c:\log.txt
(Reporter)

Comment 9

15 years ago
Peter:

As I said before in emails to you, I can't manage to get anything from trying to
use those two strings you mention.  With either string used in Win98SE
'Start'/'Run'(what I assume your reference to "run" means), it just says, "Can't
find file."

Ray
(Reporter)

Comment 10

15 years ago
I further note that all www.irs.gov PDF files I've tried work in Mozilla,
although no files from other US govt. agencies do.  E.g., this one works:

http://www.fec.gov/votregis/pdf/nvra.pdf

Can't anyone tell me what the difference is between those files that work and
those that don't?  This one also works:

www.chelanpud.org/relicense/study/reports/5103_1.pdf

This one does not work:

http://www.cde.ca.gov/fiscal/financial/SARC0001.pdf

The one I list above that gives Error #503 in Moz doesn't show anything in Netsc
4.8, so I guess its irrelevant to this bug.

And why is it Bugzilla's list of my bugs doesn't include my so-called
"unconfirmed" bugs, such as this one?

Win98SE, Moz 1.5, AcroRead 6.00 plugin for Netscape in Moz Plugins folder (no
AcroRead helper association), (Acroread set to display within browser)

If you don't use the above software, you can't attribute this bug to some fault
unique to my system.  You Moz types claim Moz 1.5 works with AcroRead 6.00 and
its Netscape plugin, nppdf32.dll, right?

Ray

Comment 11

15 years ago
I was able to open
http://www.sgsd.k12.wi.us/central/Employee%20Information/dental/Dental%20Directory%202-02.pdf
without any problems in win98se and Acrobat 6.00.

Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7a) Gecko/20040111



(Reporter)

Comment 12

15 years ago
Still doesn't WFM here.  Moz 1.6b, Win98SE, AcroRead 6.0 set for display within
browser, Netscape plugin for the latter.

Ray
(Reporter)

Comment 13

15 years ago
OK, I downloaded and installed Moz 1.6 (released), in its own folder, leaving
1.6b intact in its folder, and added nothing to its 1.6's Plugins folder.  Only
the null plugin was in the latter folder.  'Help'/'Plugins' showed the AcroRead
plugin, as well as most of the plugins in the 1.6b folder, including the Java
plugins installed in 1.6b (1.4.2_02).  With that situation, I still could not
display any of the PDF files from the Web that I could not before.  I then
downloaded Java 1.4.2_03, to see whether that would correct my other main
problem with Moz -- its crashing when loading certain Web pages that use Java. 
[See the relevant bug reports for that problem.]  1.6 'Help'/'Plugins' then
showed this new version of Java.  In the following and in the mentioned reports
on the Java bug(s), I'm assuming, then, that Moz first looks at its Plugin
folder for at least a certain selection of plugins to use, and then checks for
later versions of them anywhere else on my hard disk and uses the latter if it
finds a later version of such, or any version of such when none is in the former
location.

Next, I created a new profile in 1.6 (which I called 'Placater').  I didn't add
anything into it.  I don't know what those here who insisted I try this expect
to be in the new profile they wanted me to try.  I then tried to display the
PDFs I couldn't display in my usual profile (Default User) in Moz, using this
new profile.  Of course, these PDF files still didn't display.

I would like to point out two things:

1. With any profile, http://www.fbi.gov/pressrel/pressrel01/mail3.pdf (12 page)
and http://www.irs.gov/pub/irs-pdf/18863.pdf (3 pages) and many other U. S.
government pages do display using any version of Moz and any profile I've
created.  Nobody here seems to want to deal with considering that.

2. When I try a Web page that does not display, there is a time period,
apparently that required to download it, and then an AcroRead error window
appears which says:  "The file does not begin with '%PDF-'."  Nobody here seems
to want to claim knowledge of what '%PDF-' means, and I have not found
elsewhere, so far, reference to how Moz manages to clip this prefix from almost
all PDF files.


An Argentine site gives a clumsy work-around (unless you want to save the file
anyhow):

"• Aparece el mensaje de error "File does not begin with '%PDF-'"

Si Acrobat Reader se inicia inesperadamente después de haber bajado un archivo y
aparece el mensaje de error "File does not begin with '%PDF-'", mantenga
presionada la tecla "Shift" mientras hace click en el enlace del archivo que
desea bajar."

This works (in Moz 1.6, using Default User profile) for the file James says,
above, that he can download in Win98.

But hey, who is this guy who has my first name as his last name?  No wonder I
can't make this browser work right!  It takes more than lots of eyeballs,
Buster!  Something has to be connected to such.  It says here that bug reports
submitted by those who don't write software are useful.  I don't write software
and I don't see the most important bug reports I submit becoming useful at all.

To quote Eric S. Raymond, "Given enough eyeballs, all bugs are shallow.

"Opportunities to contribute abound for those who may not write software, but
who wish to exercise the daily Mozilla builds and constructively report the bugs
that they discover. Bugs reported by the rest of the world receive equal
attention to the bugs submitted by Netscape employees."

If this bug and the Java Moz-crashing bug I've reported appear specific to MY
system, either its particular build:

35200-OEM-0088937-09881

is relevant, or else I have some particular application that conflicts with Moz,
only in respect to these two problems, display of most but not all PDF files and
not crashing Moz with certain Java-embedded Web pages.  Of course, I
additionally never trust what goes in Windows Registry.  But I am no software
expert, and your Moz Project pages say I don't have to be; thus I see it as the
obligation of those of you who DESIGN Moz -- considering that you advertising it
as replacing other general-purpose browsers on all graphic Windows platforms --
to dig into the sources of these two bugs I report. . .as I do not understand
the guts of your browser or of AcroRead, Java runtime software or the other
browser which don't exhibit these bugs.

The last time I checked, on my system, the bug of Report 193528, its page didn't
even display, let alone print; so I guess it, and also Report 219235 basically
cover the same bug as this report.  Combine these three if you wish.

Ray

Comment 14

15 years ago
Bug 207417 comment #40 mentions uninstalling Acrobat 6 and reinstalling the
older version 5 as a workaround. Comment 31 gives a different workaround (which
is not so different from the one from Argentina here. You may as well
right-click and "Save link target as" to save your pdf files to your harddisk
first and then open it directly in the Windows Explorer.

Nice to see that you created a new profile, but obviously it was not as clean as
it should have been: you said you didn't install anything into it, but you still
had the Adobe plugin working (or: not working). There are several plugin
locations Mozilla looks at. Not the whole HD, but at least in the application
directory, the profile directory, the root of the profiles, and I'm quite sure
it also looks at the Netscape plugin directories. So as long as about:plugins
does show Java and/or Adobe, the new profile isn't that new.

> But I am no software expert, and your Moz Project pages say I don't 
> have to be;

For reporting bugs? No. But the experts still cannot magically know what goes on
on your system.

> thus I see it as the obligation of those of you who DESIGN Moz

Nobody has any obligation, at least not more than you have yourself, to spend
their spare time for solving your problem or doing anything else for Mozilla.
Only because you appear willing to spend your time (I appreciate that), I spent
mine.

> I don't know what those here who insisted I try this expect
> to be in the new profile they wanted me to try.

I've explained this many times. This is standard procedure, solves such problems
in most cases and helps finding the problem in many. 
And having commented on more than 1000 bugs, I have never seen anybody who keeps
questioning other's advice as hard as you do. But that's not all: I cannot
remember more than 1 or 2 of your comments not containing insults and
accusations or at least taunt although being asked several times to stop it.

Call me again when you got yourself under control and got rid of your sarcasm.
Until then, I'm out of this game.
(Reporter)

Comment 15

15 years ago
See Comment #13 of PDF-file Bug 220757 in re no change in behavior of any of the
PDF=file-nondisplay or Java-Moz=crashing bugs after my creation and use of a new
profile.

In response to Andreas' Comment #14 of Bug 220757, on this non-fix, I have the
following to say:

As to the non-newness of my "new" profile, "Placater", due to Moz's finding
previous AcroRead and Java plugins elsewhere in Moz and Netscape folders:  Any
time you have software that gets that intrusive, it should include the ability
to disable such scavenging.  Can I disable this in Moz?  I'm not going to take
all these plugins out of earlier Moz versions and my Netscape 4.79 and 4.8
programs.  I see this as all off in the wrong direction anyhow.  The AcroRead
6.0 Netscape plugin DOES work right in Netscape 4.79 and 4.8.  If it doesn't
work right in versions of Moz for me, that means Moz is trying some flaky way of
using this plugin designed for Netscape 4.x (also 6.x, 7.x?).  Please inform me
how to disable Moz 1.6's capability of scrounging around outside its own program
for plugins, and I can then test a new profile, and plugin folder empty of all
AcroRead and Java plugins, without having any effects from plugins outside of
Moz 1.6.

>So as long as about:plugins does show Java and/or Adobe, the new profile >isn't
that new.

Are you saying that something in the profile controls the ability of Moz to grab
plugins from locations outside itself?

>> But I am no software expert, and your Moz Project pages say I don't 
>> have to be;

>For reporting bugs? No. But the experts still cannot magically know what >goes
on on your system.

So what happened to your Talkback magic?  Another bug comment somewhere said
that maybe Moz 1.6 contained it.  The 1.6 download page doesn't mention it and
it never shows when Moz crashes from its Java-incompatibility bugs.  Is Moz
having trouble getting Netscape to pay for Talkback in Moz?  But if, as it is
said, Talkback doesn't always talk back on crashes, I guess it doesn't have
enough magic for us, does it?

>> I don't know what those here who insisted I try this expect
>> to be in the new profile they wanted me to try.

>I've explained this many times. This is standard procedure, solves such
>problems in most cases and helps finding the problem in many. And having
>commented on more than 1000 bugs, I have never seen anybody who keeps
>questioning other's advice as hard as you do.

Well, I've tried to get "tech supports" to clear up problems in software; and
I've found that even supervisors in them dump "standard procedures" on me when
there are strong indications that such are totally irrelevant; and that's
exactly what they turn out to be.  The last time was when I had an HP
tech-support supervisor play the problem I had, on HIS machine.  The problem
turned out to be a bug in the Veritas software HP used to achieve RAM action
with its DVD+R/W unit.  (I know; tech-support people don't write the code.)

The number of bug comments in my email has gotten pretty out-of-control, but let
me know if you have an easy way to make a version of Moz only look at plugins,
and whatever else is of concern, that are explicitly put into its own files --
or else have a very different approach to unearthing the cause(s) of these
AcroRead and Java incompatibilities with Moz 1.6 (or such later version that
should evolve).  I wish to use the form-fill=in-and-print capability of Acrobat
6.0.  As I recall, 5.0 does not have this or it isn't as complete or something;
thus I do not want to replace 6.0 with 5.0.  I saw a reference to an AcroRead
6.01 (that was said not to fix much), but it doesn't show up on Acrobat's Website.

I note that you completely ignore the two points I enumerated in my Comment #13
of Bug 220757.

Ray

Comment 16

15 years ago
RE: Comment #9

For an explanation of Peter's comment #8, see
http://www.mozilla.org/projects/netlib/http/http-debugging.html.  This provides
more detailed instructions.  I would recommend using:

  C:\> set NSPR_LOG_MODULES=nsHttp:3
  C:\> set NSPR_LOG_FILE=C:\log.txt

  C:\> cd "Program Files\mozilla.org\Mozilla"
  C:\Program Files\mozilla.org\Mozilla\> .\mozilla.exe

Another way to get HTTP headers is to use this HTTP viewer: 
http://www.rexswain.com/httpview.html.  Select 'HEAD' to avoid seeing the huge
amount of data for the PDF file itself.  There's also a Mozilla extension,
LiveHTTPHeaders, at http://livehttpheaders.mozdev.org/index.html.

RE: comment #3

If you look at the actual data of a PDF file, the beginning contains the string
"%PDF-" to identify it as a PDF file.

Comment 17

15 years ago
Raymond, I've viewed the HTTP headers my computer got for all the PDF files that
still have valid links here, and I can't see any definite pattern as to why some
work for you and others do not.  It could be that just the larger files are
giving you trouble.  All the PDF files you've listed seem to work for everybody
else, so it looks like the problem lies somewhere within your Mozilla or Adobe
installation.  Unfortunately, I don't yet know much about Mozilla profiles or
plugins, so I can only guess about what is going on.  Perhaps Mozilla and
Netscape 4.x are interfering with each other, or the Adobe plugin for one
inteferes with the Adobe plugin for the other. 

Just to clarify things, are you able to download the PDFs and view them
externally (so that your problem is only with viewing them inside Mozilla)?  
BTW, Acrobat 6.0.1 is out now.

Comment 18

15 years ago
WFM.

Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7b) Gecko/20040330
Microsoft Windows 2000 Pro 5.00.2195 SP4
Adobe Acrobat Plug-In Version 6.00 for Netscape (nppdf32.dll)
(Reporter)

Comment 19

15 years ago
At the present time, I get only this response when submitting this URL:

     Error #503
     BW:E1032: can't get address of 'intl.ajkd.org'
     BoostWeb BW4.2.27.2 Oct 09 2003 at compression04.oak.mdsg-pacwest.com

I've gotten this response to a few URLs in the past but never understood what it
means.  I'll try again later.

Win98SE
Moz 1l7b
AcroRead 6.0

Updated

15 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME

Updated

9 years ago
Component: Plug-ins → PDF (Adobe)
Product: Core → Plugins
QA Contact: bmartin → adobe-reader
Version: Trunk → unspecified
Product: Plugins → Plugins Graveyard
You need to log in before you can comment on or make changes to this bug.