Allow grouping of products in the presentation of enter_bug

VERIFIED DUPLICATE of bug 224208

Status

()

--
enhancement
VERIFIED DUPLICATE of bug 224208
15 years ago
12 years ago

People

(Reporter: ludovic, Assigned: myk)

Tracking

Details

Attachments

(2 attachments)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20030925
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20030925

This patch allows grouping of products when choosing the product in
enter_bug.cgi as well as in the admin interface.. Each product can be given a
group name and when you go to enter_bug you will be presented with groups of
products in a similar way as bugzilla.mozilla.org (I'm not sure there is a patch
for the way enter_bug is done on bugzilla.mozilla.org)..

The patch is for 2.17 Head code of Sept 30th 2003

Reproducible: Always

Steps to Reproduce:
(Reporter)

Comment 1

15 years ago
Created attachment 132415 [details] [diff] [review]
Patch for 2.17 Head of Sept 30th 2003

Patch for the above specified feature.
bug 174298 is the one that accomplished what you see on bugzilla.mozilla.org. 
It was pretty much a site-specific hack.  If this works out well, they could
very likely drop the hack next time they upgrade after this goes in. :)

I think I heard mention of Joel doing something along these lines on his site
too...  ccing for comment
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Linux → All
Hardware: PC → All
Target Milestone: --- → Bugzilla 2.18

Comment 3

15 years ago
Mine is also something of a hack.  (OK, it's really a hack)
However, the right approach is probably similar.

What we need to do is to define a MenuGroup table with Menu group ids, Menu
group names, and menu group descriptions.  It should be possible to assign each
product to a menu group id (by picking the name from a drop-down list in
editproducts).

Then, if a user has entry privileges on more than one menugroup, the "select the
product" template should present the choices in a hierarchy.  Ideally, it should
be possible to customize between a) Selecting the menu group and then the
product within it and b) Presenting all the products, but organizing them in
Menu groups.
(Reporter)

Comment 4

15 years ago
Created attachment 132531 [details] [diff] [review]
Patch against 2.17 for a picker for prod groups. Needs Bug 102852


This is an additional patch which needs the previous patch as well as the
picker patch in Bug 102852.. It allows to pick product groups directly from
already existing entries in the database.
(Reporter)

Updated

15 years ago
Attachment #132415 - Flags: review?

Comment 5

15 years ago
Either this is a dupe of bug 224208 or vice-versa

Comment 6

15 years ago
Comment on attachment 132415 [details] [diff] [review]
Patch for 2.17 Head of Sept 30th 2003

Slightly bitrotten.
Attachment #132415 - Flags: review? → review-
(Assignee)

Updated

15 years ago
Assignee: myk → ludovic
Target Milestone: Bugzilla 2.18 → Bugzilla 2.20
Bugzilla 2.20 feature set is now frozen as of 15 Sept 2004.  Anything flagged
enhancement that hasn't already landed is being pushed out.  If this bug is
otherwise ready to land, we'll handle it on a case-by-case basis, please set the
blocking2.20 flag to '?' if you think it qualifies.
Target Milestone: Bugzilla 2.20 → Bugzilla 2.22

Updated

13 years ago
Assignee: ludovic → myk
QA Contact: mattyt-bugzilla → default-qa
Target Milestone: Bugzilla 2.22 → ---

Comment 8

12 years ago
Here is an old bug that I don't understand, it appears to suggest something along the lines of the classification feature used to group products but I am not sure. If anyone understands this bug could you give it a little direction? I think the bug is a little out of date.

Comment 9

12 years ago
I agree with comment 5.

*** This bug has been marked as a duplicate of 224208 ***
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE

Updated

12 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.