setting |status| doesn't act like setting |window.status|

RESOLVED WONTFIX

Status

()

Core
DOM: Core & HTML
RESOLVED WONTFIX
15 years ago
10 years ago

People

(Reporter: Jozef Riha, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4b) Gecko/20030516 Mozilla Firebird/0.6
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4b) Gecko/20030516 Mozilla Firebird/0.6

when page loaded in konqueror/IE it displays the persons' names in status bar
when mouse is over their heads. does not work in mozilla.

Reproducible: Always

Steps to Reproduce:
It works if you use window.status instead of just status.  As I seem to recall,
this was done purposefully to fix bug 110397 (which gave us NS4 compat).  Not
sure why we need NS4 compat on "status", exactly....

Updated

15 years ago
Summary: status not displayed on mouseover → setting |status| doesn't act like setting |window.status|
Assignee: general → general
Component: Browser-General → DOM: Level 0
QA Contact: general → ian
This was done to prevent code that does:

  var foo = ...;

where "foo" is something like "status", "location", ... from actually changing
the status or location of the page. 4x and IE are not ECMA compliant and treat
the above differently from:

  foo = ...;

Mozilla's JS engine was made ECMA compliant a long time ago and that caused
scripts on pages to work in unexpected ways. The current scheme is believed to
break less than the alternative, even if it's not ideal. There is no fix for
this bug that does not involve breaking ECMA compliance.

Marking WONTFIX.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WONTFIX
Is there an ECMA-262 errata for this? Seems like it would be good to make sure 
everyone is interoperable on it.

Updated

11 years ago
Duplicate of this bug: 212916

Updated

10 years ago
Duplicate of this bug: 429317
You need to log in before you can comment on or make changes to this bug.