font="arial" prints times new roman

RESOLVED FIXED

Status

()

Core
Printing: Output
RESOLVED FIXED
14 years ago
4 years ago

People

(Reporter: k b, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6a) Gecko/20030929
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6a) Gecko/20030929

on my linux machine pages displaying the arial font are printed with times new
roman. 

Reproducible: Always

Steps to Reproduce:
1. load any page with some font tag saying face="arial"
2. view the page (on screen), looks good.
3. print, print is not with arial
Whiteboard: DUPEME

Comment 1

14 years ago
Using 1.5rc1 on Mandrake 9.1, with only the default fonts installed, I can print
http://members.ij.net/mrmazda/auth/font-arial.html to a ps file, and gv shows me
something that appears to be Arial, but I suspect is actually Helvetica, since
Arial is not installed. Is Arial even installed on your system?
(Reporter)

Comment 2

14 years ago
your right.
i do not have arial on my system. however an arial-like (helvetica?) is
displayed in browser but not printed.

when i tried to print to a postscript file, the same problem occured.
if font face is arial then it prints times.

if font face is arial, helvetica. then it works good. so it seems like it tries
one by one, but if there is no match it falls back on default instead of trying
a close font.

Comment 3

14 years ago
Things to try to work around:
1-Change your default from serif to sans-serif
2-Install Arial (from mswbfnts.zip
http://download.au.kde.org/pub/hobbes/multimedia/fonts/mswbfnts.zip, or import
from /mnt/win_C/fonts if it exists)
3-Create an alias from Arial to something you do have installed, such as Helvetica

Comment 4

13 years ago
k b <k_b0000@yahoo.se>: Is this still an issue in new builds?
(Reporter)

Comment 5

13 years ago
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b2) Gecko/20050308

it is still an issue. but then i have not tried the suggestion in comment 3
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/
(Reporter)

Comment 7

12 years ago
well, after the automated message i think this can ble closed as INVALID or
WORKSFORME.

especially if this problem does not exist in firefox.

Comment 8

10 years ago
Resolving as FIXED by the move to cairo-based printing. The current printing code should be able to print with any font that can be displayed.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED

Updated

4 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.