Last Comment Bug 220833 - view page info/forms shows id, not name attribute
: view page info/forms shows id, not name attribute
Status: RESOLVED FIXED
:
Product: SeaMonkey
Classification: Client Software
Component: Page Info (show other bugs)
: Trunk
: x86 Linux
-- normal (vote)
: ---
Assigned To: Daniel Brooks [:db48x]
: Patty Mac
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-30 13:47 PDT by Deron Meranda
Modified: 2004-11-22 17:25 PST (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description User image Deron Meranda 2003-09-30 13:47:12 PDT
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030701
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030701

The Forms panel in View Page Info appears to display an input element's "id"
attribute value for the "Field Name" column instead of the "name" attribute. 
The "name" field is most important because that is what is sent back to the web
server on a submit.  This is especially important for radio-button style input
elements since each element must have a unique id value (if present at all), but
should share the same name value (in the same button group).

Reproducible: Always

Steps to Reproduce:
1. Make a simple HTML form with multiple input elements in the form
2. Give each element a unique id value, but sharing the same name value
3. Load the page and then use View Page Info..Forms.

Actual Results:  
Field Name shows the value from the id attribute, not the name attribute.

Expected Results:  
Show the value of the name attribute, regardless of any id attributes.

This is even in standards compliance mode (XHTML 1.0 strict).
Comment 1 User image Christopher Aillon (sabbatical, not receiving bugmail) 2003-09-30 15:39:35 PDT
The problem seems to be this line:

http://lxr.mozilla.org/mozilla/source/xpfe/browser/resources/content/pageInfo.js#642
Comment 2 User image Daniel Brooks [:db48x] 2003-09-30 20:04:40 PDT
huh. I'd swear I've fixed that before.
Comment 3 User image Daniel Brooks [:db48x] 2004-01-13 20:37:39 PST
checked in, marking fixed
Comment 4 User image Daniel Brooks [:db48x] 2004-01-13 20:38:23 PST
(it was fixed in the patch for bug 226752)

Note You need to log in before you can comment on or make changes to this bug.