Compiling with -O3 or -funroll-loops fails in mozilla/gfx

RESOLVED DUPLICATE of bug 214818

Status

RESOLVED DUPLICATE of bug 214818
15 years ago
10 years ago

People

(Reporter: e_mayilme, Assigned: sfraser_bugs)

Tracking

Trunk
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.5b) Gecko/20030913 Camino/0.7+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.5b) Gecko/20030913 Camino/0.7+

I've compiled Mozilla and Camino several times within the past year, and have
always found that gcc cannot compile it if -O3 and/or -funroll-loops is used.

The problem comes up only in the gfx directory. It seems like all of the rest of
the code can be compiled with these optimizations.

The errors that are produced look something like this:

non-virtual thunk [nv:-4] to nsPrintOptions::AddRef()
non-virtual thunk [nv:-4] to nsPrintOptions::Release()


The reason I'm reporting this is because I want to compile a G5-optimized
version of Camino 0.8, when it comes out, and I would prefer to be able to use
all of the available optimizations.

Hopefully it is just a small error, and I appreciate it if someone can fix it.

I'm currently using gcc 3.3 (latest Apple release), but the problem also occurs
with previous versions of the compiler. I have gcc 3.3.1 as well, but I have not
tried that, since I won't be using it to compile for the G5.


Reproducible: Always

Steps to Reproduce:
So.. typically, when adding optimization options makes code not compile that's a
bug in the optimizer....
*** Bug 271328 has been marked as a duplicate of this bug. ***

Comment 3

14 years ago
(In reply to comment #0)
> User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US;
rv:1.5b) Gecko/20030913 Camino/0.7+
> Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US;
rv:1.5b) Gecko/20030913 Camino/0.7+
> 
> I've compiled Mozilla and Camino several times within the past year, and have
> always found that gcc cannot compile it if -O3 and/or -funroll-loops is used.
> 
> The problem comes up only in the gfx directory. It seems like all of the rest of
> the code can be compiled with these optimizations.
> 
> The errors that are produced look something like this:
> 
> non-virtual thunk [nv:-4] to nsPrintOptions::AddRef()
> non-virtual thunk [nv:-4] to nsPrintOptions::Release()
> 
> 
> The reason I'm reporting this is because I want to compile a G5-optimized
> version of Camino 0.8, when it comes out, and I would prefer to be able to use
> all of the available optimizations.
> 
> Hopefully it is just a small error, and I appreciate it if someone can fix it.
> 
> I'm currently using gcc 3.3 (latest Apple release), but the problem also occurs
> with previous versions of the compiler. I have gcc 3.3.1 as well, but I have not
> tried that, since I won't be using it to compile for the G5.
> 
> 
> Reproducible: Always
> 
> Steps to Reproduce:

(In reply to comment #2)
> *** Bug 271328 has been marked as a duplicate of this bug. ***

(In reply to comment #0)
> User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US;
rv:1.5b) Gecko/20030913 Camino/0.7+
> Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US;
rv:1.5b) Gecko/20030913 Camino/0.7+
> 
> I've compiled Mozilla and Camino several times within the past year, and have
> always found that gcc cannot compile it if -O3 and/or -funroll-loops is used.
> 
> The problem comes up only in the gfx directory. It seems like all of the rest of
> the code can be compiled with these optimizations.
> 
> The errors that are produced look something like this:
> 
> non-virtual thunk [nv:-4] to nsPrintOptions::AddRef()
> non-virtual thunk [nv:-4] to nsPrintOptions::Release()
> 
> 
> The reason I'm reporting this is because I want to compile a G5-optimized
> version of Camino 0.8, when it comes out, and I would prefer to be able to use
> all of the available optimizations.
> 
> Hopefully it is just a small error, and I appreciate it if someone can fix it.
> 
> I'm currently using gcc 3.3 (latest Apple release), but the problem also occurs
> with previous versions of the compiler. I have gcc 3.3.1 as well, but I have not
> tried that, since I won't be using it to compile for the G5.
> 
> 
> Reproducible: Always
> 
> Steps to Reproduce:
Please report this bug to Apple too since it's probably a bug in XCode Tools 1.5
 along with the November 2004 GCC 3.3 update.

Comment 4

14 years ago

*** This bug has been marked as a duplicate of 214818 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.