There is an error in XUL.mfasl which prevents nonlocal home directory users(NFS mounted) from downloading files if it existed prior to mozilla launch.

RESOLVED EXPIRED

Status

SeaMonkey
Download & File Handling
RESOLVED EXPIRED
14 years ago
12 years ago

People

(Reporter: Alexander Kohr, Assigned: Blake Ross)

Tracking

Trunk
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.5) Gecko/20030925
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.5) Gecko/20030925

If you don't have a PDF plugin(this is for a reason, In a once previously used
Profile loacated in a nonlocal home directory (NFS mounted in this case),  you
get an error message
"/private/automount/Network/Users/mygroupname/myusername/Library/Application
Registry/2jwxe7ch.PDF could not be save, because the source file could not be
read. Try again later, or contact the server adminstrator" Also once the PDF
download is busted it busts the ability to download other file types as well,
that you were previously able to download as well when you had the PDF plugin.
Thsi does not occur in a local user.

Reproducible: Always

Steps to Reproduce:
1.Be logged in as a nonlocal user (NFS mounted home directory in this case)
2.Remove any pdf plugin you might have
3.Launch mozilla
4.Locate and click on a pdg file to download
5.In the what to do dialog box,Select Adobe acrobat reader as the application to
open the file
6.when it finishes downloading quit mozilla and acrobat.
7. Relaunch mozilla
8. Download another or event he same pdf file

Actual Results:  
I get an error message that says
/private/automount/Network/Users/mygroupname/myusername/Library/Application
Registry/2jwxe7ch.PDF could not be save, because the source file could not be read. 
Try again later, or contact the server adminstrator

Expected Results:  
The file to be opened in acrobat so that i could read it.

I can work around it by instead of launching mozilla directly I run a command
script prior that will rm the file in
~/Library/Mozilla/Profiles/profilename/seemingly_usless_garbage_letter_directory.slt/XUL.mfasl
and then launches mozilla

As an FYI:This problem also occurs in mozilla 1.4 and Netscape 7.1
Brendan, why would XUL.mfasl affect this??

Comment 2

14 years ago
At last a clue why Mozilla crashed every time I try to download anything, or
even open the Download Manager.  It had to be just me since I saw no bug reports
about it. I knew I didn't have the PDF plugin, in fact I didn't know if there
was one.

 After reading this Bug report, I got the pdf plug-in for Mozilla (using
Explorer) and now I can download again!  
I began by choosing "About Plug-ins" under Help in the Mozilla menubar.
seeing no PDF plugin, I used the link provided, to http://plugindoc.mozdev.org/
and located the PDF plugin link. (this was a little out of date but I sent
feedback so it could be fixed.) 
Copying the URL to Explorer I downloaded.  
After install according to the Readme in the main Library (all Users) Internet
Plug-Ins folder.  
Using a fresh Nightly Build of Mozilla, 20031000105, I tried a PDF file and it
worked in the browser.  
I found an image and used "Save Image As..." (download) and that worked too. 
I opened Download Manager from the Menubar->Tools and that worked too!  

Thank you thank you thank you.

To test it I should delete the Plugin I just got and try again, forgive me if I
don't do that.

Why the problem - don't know, but under Mozilla's Package Contents, the plugins
for Mozilla are in at least two places.  Defaultplugin is under MacOS folder,
and another is in Plug-ins folder.  I guess you all know about that, but I've
noticed since the beginning that plug-ins are scattered all over the place.

Polly

PS
The same webpage has an application-specific PDF plugin for Explorer 5. It works
too!
Product: Browser → Seamonkey
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/
This bug has been automatically resolved after a period of inactivity (see above
comment). If anyone thinks this is incorrect, they should feel free to reopen it.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → EXPIRED
You need to log in before you can comment on or make changes to this bug.