If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

If tab width expands sufficiently to trigger tab scrollbar, page reloads

RESOLVED INVALID

Status

SeaMonkey
Tabbed Browser
--
minor
RESOLVED INVALID
14 years ago
9 years ago

People

(Reporter: nemo, Unassigned)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030624
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030624

I have tabs set with min/max widths as well as fitting to page title.
This leads to following annoying situation:

Reproducible: Always

Steps to Reproduce:
1. Open enough tabs so that they fill screen.
2. Visit a site that just fits on page in last tab when "Loading" title is
visible, but that has a title that will cause the tab to expand over and trigger
scrollbar.

Actual Results:  
A) Once site loads, title changes, triggering scrollbar.  
B) Mozilla does a reload.  
C) This shrinks the tab, removing the scrollbar.  
D) Go to A) infinitely or until more or less tabs are added.

Expected Results:  
I don't think reload should be triggered at all in this situation.
(Reporter)

Updated

14 years ago
Component: Browser-General → Tabbed Browser
What site is this? Does the site trigger a reload on resize events or something
like that?

Also, how are you setting the tab width preferences exactly?  Those are not
Mozilla preferences?  Are you using Multizilla or something?
(Reporter)

Comment 2

14 years ago
This seems to be with any site.  In any case it is not a question of the *page*
resizing - that the site could conceivably be aware of.  It is a question of the
tab expanding causing scrollbar to appear which does shrink the viewpane by a
few pixels, but also triggers a page reload.

The min/max thing is actually not that critical.
The critical component is a tab expanding in size such that it triggers the
scrollbar on the tabbar.

For min/max I am using TabExtensions project which provides interface to these
mozilla values saving the trouble of editing tabextensions.js in default or
using about:config
There are no such prefs without the TabExtensions extension...  Please file this
bug on the authors of TabExtensions.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
(Reporter)

Comment 4

14 years ago
You're marking invalid awfully quickly, even though I said min/max wasn't really
part of the bug.
Is this because you're convinced the bug is unreproduceable without tab
extensions, or you've just tried and haven't succeeded in reproducing?
(Reporter)

Comment 5

14 years ago
But, I do apologise for the assumption about the extensions - since the
TabExtensions XPI is so tiny, I always assumed it was interface only without
looking into it.

Credit to mozilla modularity, really.
I'm convinced it's because the bug is not reproducible without tab
extensions.... (based on code inspection of the tabbrowser code).
(Reporter)

Comment 7

14 years ago
Well, did more than I had :)
Righto, sorry 'bout filing before debugging...
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.