Cannot delete a 3 level deep sub folder from the local folder. Sub folder node still show after moved to Trash.

RESOLVED WORKSFORME

Status

SeaMonkey
MailNews: Message Display
RESOLVED WORKSFORME
14 years ago
10 years ago

People

(Reporter: Joe Wang, Unassigned)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20030925
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20030925


In the Mozilla 1.5, I attempted to create a two level deep sub-folder
for one of my mail account.  I then attempted to delete one of the sub
folder and the delete action failed.  The sub-folder still persist in
the folder tree view.

Reproducible: Always

Steps to Reproduce:
- Created a sub folder under local folder called "jobs"
- Created two sub-folders under the "jobs" folder called "kron1" and "kron2"
- Attempt to delete the "kron1" folder.


Actual Results:  
The "kron1" folder gets moved to the Trash folder but it is not removed from the
current folder tree view.


Expected Results:  
After I delete the "kron1" folder, it should be moved to the Trash folder
and the "kron1" folder should disappear from the folder tree.
(Reporter)

Comment 1

14 years ago
One quick thought about this bug.  It could be caused because
the folder that was attempted to delete was created having the 
"/" in its name. And it seems like the application created the
folder but couldn't delete the folder with that character as
part of the name.

Comment 2

13 years ago
I have the same problem however it occurred for a one level deep folder in
"local folders". The folders were created as follows:
1) I created a "new folder" and then changed my mind. It remained in the tree
with the name "new folder".
2) At a later date I created another new folder which was automatically named
"new folder 2". When I noticed that I had two "new folders" I cancelled the
created the creation and went back to use the old one. I found that it was
unuseable. I get a message that the "writing to the folder failed. Try deleting
trash and compacting all folders". 
3) I then tried to use the "new folder 2" and got the same problem. So, I have
two folders which remain in the tree but which can neither be used or deleted.

However, if I try to create a new folder and give it a new name immediately,
there is no problem. The folder can be used and deleted. The source of the
problem seems to be the delay. That is, by not giving a "new folder" a different
name immediately it becomes a useless tree entry that cannot be removed. 
Product: Browser → Seamonkey

Comment 3

13 years ago
I got similar problem in 2 workstations with XP.
When I click on delete key or use the popup menu, the cursor change to the
Hourglass and the folder is not deleted. But it didn't halt Mozilla: when I
click on another folder, the arrow cursor came back.

I have Mozilla on 12 workstations with Mozilla 1.7.5 and only XP stations
reported this error.

Comment 4

13 years ago
Created attachment 178847 [details]
new folder

New folder

Comment 5

13 years ago
Created attachment 178848 [details]
delete & rename options not present

delete & rename options not present

Comment 6

13 years ago
I have discovered that if i create a new sub folder below "Local Folders", with
a magic name "Inbox", then i can no longer rename and/or delete that folder...
Confirmed in Mandrake 10.1 with mozilla 1.7.6 . Don't know why exactly. Is there
any workaround available?

Thank you!

Updated

13 years ago
Assignee: sspitzer → mail

Comment 7

12 years ago
I confirm this bug; happened to me creating a 3 deep email folder. I'm using
Mozilla 1.7.8. Would like to know how to fix/repair the mail folders to get rid
of empty ones.

--rickcasey

Comment 8

10 years ago
WFM with Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b5pre) Gecko/2008032601 SeaMonkey/2.0a1pre. The folder creation/deletion code is cross-platform so this unlikely to have been WinXP specific.

The problem that hexbin saw is different, special folders are handled, well, specially. I think there are bugs about that.

For both cases, if still required: workarounds for messed up index files are to use the "Rebuild Summary File" button (to be found under folder context menu -> Properties...) or to just work with the files/directories in the subdirectory "Mail/Local Folders" of the SeaMonkey/Thunderbird profile (see http://kb.mozillazine.org/Profile_folder_-_SeaMonkey). For that use OS level tools like file managers and keep in mind that you should take backups of the profile in case something is accidentally deleted.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.