Status

defect
P3
normal
VERIFIED WORKSFORME
20 years ago
15 years ago

People

(Reporter: nbaca, Assigned: naving)

Tracking

Trunk
Future
All
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta3-] relnote-user)

(Reporter)

Description

20 years ago
Build 1999121612M12: NT4
Will need to try Linux and Mac.

Overview: Move a message to a second folder. Undo and notice that the message
reappears in the first folder but is not removed from the second folder.

Steps to reproduce:
1. Open Mail to an IMAP account
2. Select a message and move it to a second folder
3. Select Edit/Undo

Actual Results: The message displays again in the first folder but it is not
removed from the second folder.

Expected Results: Undo should remove the results of the action. In this case it
should have removed the message from the second folder.

Additional Information:
- Copy a message, Undo and notice that the message is not removed from the
second folder.
- Delete, Undo and notice that the message remains in the Trash folder.
- Undo works as expected using POP.

Updated

20 years ago
Assignee: phil → jefft
Target Milestone: M16

Comment 1

20 years ago
Reassign to jefft

Updated

20 years ago
Status: NEW → ASSIGNED

Comment 2

20 years ago
Hmm... It used to work.

Comment 3

20 years ago
Could it be because we're not updating the destination folder so we don't know
the uids in the dest folder? (I'm not suggesting that we update the destination
folder!)

Comment 4

19 years ago
Mass moving M16 to M17 - look for nsbeta2 before anything else.
Target Milestone: M16 → M17

Comment 5

19 years ago
Moving to M18 and nominating for beta3.
Keywords: nsbeta3
Target Milestone: M17 → M18

Updated

19 years ago
QA Contact: lchiang → laurel

Updated

19 years ago
Keywords: mail2

Comment 6

19 years ago
- per mail triage
We'll do an assessment of where Undo stands (ie. how broken it is) and decide if 
we need to remove this feature rather than have it not working as expected for 
people.
Whiteboard: [nsbeta3-]
Target Milestone: M18 → Future

Updated

19 years ago
Keywords: relnote3, relnoteRTM

Comment 7

19 years ago
sorry for the extra email. Removing mail2 keyword.
Keywords: mail2
Whiteboard: [nsbeta3-] → [nsbeta3-] relnote-user

Comment 8

19 years ago
reassigning jefft's bugs to naving
Assignee: jefft → naving
Status: ASSIGNED → NEW
(Assignee)

Comment 9

18 years ago
marking worksforme using latest debug build. 
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME

Updated

18 years ago
QA Contact: laurel → sheelar

Comment 10

18 years ago
verified worksforme on below builds with simple test cases with both move and 
copy of single message and undo clears the message from the destination folder. 
However some known bugs with undo menu items not enabled at times. 
2001052909win98
2001052908linux
2001052908mac
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.