Crash on startup (with GTK+2, without GNOME)

RESOLVED DUPLICATE of bug 221217

Status

Core Graveyard
File Handling
--
critical
RESOLVED DUPLICATE of bug 221217
15 years ago
2 years ago

People

(Reporter: Darren Salt, Assigned: blizzard)

Tracking

({crash})

Trunk
x86
Linux
crash

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6a) Gecko/20031001 Firebird/0.7+
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6a) Gecko/20031001 Firebird/0.7+

Mozilla (well, Firebird) crashes during startup.

Reproducible: Always

Steps to Reproduce:
1. Start the browser (as normal).
Actual Results:  
Crash (sig11), without so much as opening a window.


With the --debug switch and a backtrace, I found that the bug was an attempted
branch through zero from nsGNOMERegistry::Startup()
(uriloader/exthandler/unix/nsGNOMERegistry.cpp).

The fix is to check for gnomeLib == 0 in the above method and to return early
without initialising GNOME. (It is sufficient to place this check before the
call to _gnome_program_init.)

Updated

15 years ago
Keywords: crash
bryner, this should be yours, right?

Comment 2

15 years ago
This sounds like a possible duplicate of bug 221217
(Reporter)

Comment 3

15 years ago

*** This bug has been marked as a duplicate of 221217 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Component: GFX: Gtk → File Handling
Resolution: --- → DUPLICATE
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.