onmouseover function does not work properly - animated gifs only loop once

RESOLVED DUPLICATE of bug 210001

Status

()

Core
DOM: Events
RESOLVED DUPLICATE of bug 210001
15 years ago
15 years ago

People

(Reporter: Sven Behling, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20030925
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20030925

I created a html code with a java part what should show a gif "Gate1". If you
move mouse over this gif it changes to a gif animation "Anim1" which runs one
time until and stops. If you leave this area and move the mouse again to the gif
then the ani starts again. Unfortunately since Mozilla 1.4.x it does not work
anymore. Mozilla 1.5rc2 does work too. Version 1.2.1 works flawless. Windows
version 1.4.x shows same error. IE6.0 and since opera 7.20 it works perfect.

Sorry for german text in the code but the should be clear enough.
--------------------------------------------------------------------------
<script type="text/javascript">
<!--
Gate1 = new Image();
Gate1.src = "gif/navbutton1.gif";     /* first standard-gif */
Anim1 = new Image();
Anim1.src = "gif/navanisw.gif"; /* first Highlight-gif */

function Bildwechsel(Bildnr,Bildobjekt) {
 window.document.images[Bildnr].src = Bildobjekt.src;
}
//-->
</script>

<!-- Button Definition Ende -->
</head>

<div style="position:absolute; top:185px; left:15px;width:40px;">
<a HREF="http://hoogie.dyndns.org/sw/swmain.html" target="main"
   onMouseOver="Bildwechsel(0,Anim1)"
   onMouseOut="Bildwechsel(0,Gate1)"><img src="gif/navbutton1.gif"
   width="120" height="40" border="0" alt="Gate1"></a><br>
</div>
-----------------------------------------------------------------------------


Reproducible: Always

Steps to Reproduce:
1.
2.
3.
Created attachment 132507 [details]
Testcase with fixed absolute URL to /pic dir.
Attachment #132506 - Attachment is obsolete: true
-> DOM, because this isn't JavaScript engine.
Component: JavaScript Engine → DOM Events
sigh, -> correct owner for triage.
Assignee: rogerl → events
QA Contact: PhilSchwartau → ian

Comment 5

15 years ago
*** Bug 221009 has been marked as a duplicate of this bug. ***
This worksforme with linux trunk builds 2003-09-24-22 and 2003-09-29-22. 
Stephend, can you actually reproduce?  Reporter, you did not switch off toggling
images like this in preferences, did you?
I see the GIF image animate only once, ever...(It's been awhile since I've
created animated gifs, but they can have parameters as to looping, yes?)
OS: Linux → All
Hardware: PC → All
Summary: function onmouseover does not work proberly → onmouseover function does not work properly - animated gifs only loop once
Oh, I see. The expectation here is that resetting the src will restart the
animation.  That's no longer the case, and may never again be the case,
depending....

*** This bug has been marked as a duplicate of 210001 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.