function onmouseover does not work proberly

VERIFIED DUPLICATE of bug 220992

Status

()

Core
JavaScript Engine
VERIFIED DUPLICATE of bug 220992
14 years ago
14 years ago

People

(Reporter: Sven Behling, Assigned: rogerl (gone))

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20030925
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20030925

I created a html code with a java part what should show a gif "Gate1". If you
move mouse over this gif it changes to a gif animation "Anim1" which runs one
time until and stops. If you leave this area and move the mouse again to the gif
then the ani starts again. Unfortunately since Mozilla 1.4.x it does not work
anymore. Mozilla 1.5rc2 does work too. Version 1.2.1 works flawless. Windows
version 1.4.x shows same error. IE6.0 and since opera 7.20 it works perfect.

Sorry for german text in the code but the should be clear enough.
--------------------------------------------------------------------------
<script type="text/javascript">
<!--
Gate1 = new Image();
Gate1.src = "gif/navbutton1.gif";     /* first standard-gif */
Anim1 = new Image();
Anim1.src = "gif/navanisw.gif"; /* first Highlight-gif */

function Bildwechsel(Bildnr,Bildobjekt) {
 window.document.images[Bildnr].src = Bildobjekt.src;
}
//-->
</script>

<!-- Button Definition Ende -->
</head>

<div style="position:absolute; top:185px; left:15px;width:40px;">
<a HREF="http://hoogie.dyndns.org/sw/swmain.html" target="main"
   onMouseOver="Bildwechsel(0,Anim1)"
   onMouseOut="Bildwechsel(0,Gate1)"><img src="gif/navbutton1.gif"
   width="120" height="40" border="0" alt="Gate1"></a><br>
</div>
-----------------------------------------------------------------------------


Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Comment 1

14 years ago

*** This bug has been marked as a duplicate of 220992 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE

Comment 2

14 years ago
Verified Duplicate
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.