Closed Bug 221020 Opened 16 years ago Closed 16 years ago

setting background color in style attribute of colgroup tag has no effect

Categories

(Core :: Layout: Tables, defect)

x86
Windows XP
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 4510

People

(Reporter: esther.berg, Unassigned)

Details

User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030624

setting a background color for columns by using the style attribute of a 
colgroup tag has no effect in the surrounding table

Reproducible: Always

Steps to Reproduce:
<table>
  <caption>
  Background Color Test
  </caption>
  <colgroup>
  	<col span="2" style="background-color:yellow;">
	<col span="2" style="background-color:green;">
  </colgroup>
  <tr>
    <td>11</td>
    <td>12</td>
    <td>13</td>
    <td>14</td>
  </tr>
  <tr>
    <td>21</td>
    <td>22</td>
    <td>23</td>
    <td>24</td>
  </tr>
  <tr>
    <td>31</td>
    <td>32</td>
    <td>33</td>
    <td>34</td>
  </tr>
  <tr>
    <td>41</td>
    <td>42</td>
    <td>43</td>
    <td>44</td>
  </tr>
  <tr>
    <td>51</td>
    <td>52</td>
    <td>53</td>
    <td>54</td>
  </tr>
</table>
Actual Results:  
in the table above no column has a yellow or green background color

Expected Results:  
in the table above the first two columns should have a yellow and the following 
two a green background.

it seems to me that every CSS property for colgroups are ignored in the 
surrounding table

*** This bug has been marked as a duplicate of 4510 ***
Status: UNCONFIRMED → RESOLVED
Closed: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.