mozilla crash when open mail window after sidebar activity

RESOLVED WORKSFORME

Status

SeaMonkey
MailNews: Message Display
--
critical
RESOLVED WORKSFORME
14 years ago
13 years ago

People

(Reporter: Wolfgang Fiedler, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

({crash, stackwanted})

Trunk
x86
Linux
crash, stackwanted

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20030925
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20030925

I can crash Mozilla 1.5RC2 on Linux and have generated over 20 talkback IDs when
finding out how to reproduce this. 
Preconditions: .) the sidebar must be open
.) a simple or no start page.

Reproducible: Always

Steps to Reproduce:
1. open mozilla
2. click in the sidebar on another tab (Tinderbox:SeaMonkey is my favorite)
3. open the mail window either with ctrl-2 or a click on the icon on the lower left.

Actual Results:  
mozilla crashes

Expected Results:  
the mail window should open

Here it comes (and don't laugh!):
If I do not open another tab in the sidebar (skip step 2) the mailwindow opens
and all is fine, 
If I open a web page, open a bookmark and then execute steps 2 and 3 from above
all is fine. 
If the mail window was open once I can not reproduce the crash anymore. Its only
the first invocation of the mailwindow.
And it must have something to do with the sidebar.
Some talkback IDs: TB24070902H TB24070792X TB24070771G  if you need more then
ask. They are all from 1.5RC2 with classic theme

Updated

14 years ago
Keywords: crash, stackwanted

Updated

14 years ago
Whiteboard: TB24070902H, TB24070792X, TB24070771G

Comment 1

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031007
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031007

A very similar thing is happening to me with Mozilla 1.5 (using Modern Theme).
But the sidebar isn't involved at all since I don't use it.

Reproducible: Sometimes (I cannot observe a regular pattern)

Steps to Reproduce:
1. Open mozilla (with blank starting page)
2. Open the mail window either with ctrl-2 or a click on the icon on the lower left.

Actual Results:  
Mozilla crashes.

Expected Results:  
The mail window should open.

Similarly, once the mail window has been opened successfully, the bug does not
happen again (until Mozilla is restarted, of course...).
Also, I've come to think that if any web page is opened between steps 1 and 2,
all is fine and nothing crashes.
A sent talkback ID: TB25499280K

Comment 2

14 years ago
Reporter: Do you still see this with a current Mozilla build? This is wfm with a
current cvs trunk build on win2k.

Comment 3

14 years ago
Right, this problem never happened again since I moved to a newer version
(Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040113
MultiZilla/1.6.2.0c).

I forgot to comment it... :P

Comment 4

14 years ago
Marc: Your problem is a different one i think

Updated

14 years ago
Whiteboard: TB24070902H, TB24070792X, TB24070771G
(Reporter)

Comment 5

14 years ago
I can't reproduce this bug anymore with my current mozilla. 

@Frank: This problem never occured in Windows. Only on Linux.

Since it is not reproducable with a recent Mozilla I think we should close this
bug. 

Comment 6

14 years ago
Marking WFM per reporter's last comment.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.