Enhancement to allow for saved/sticky/persistent cookies that don't get removed manually

RESOLVED DUPLICATE of bug 217286

Status

()

Core
Networking: Cookies
--
enhancement
RESOLVED DUPLICATE of bug 217286
14 years ago
14 years ago

People

(Reporter: nrlz, Assigned: Darin Fisher)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030624
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030624

Motivation:
Privacy concerned individuals usually purge all stored cookies after each
browser session. For a typical browser session, the individual would have
collected various cookies; some of them they may actually want to keep but most
of them are to be thrown away. The user can opt to "Remove All Cookies" at once
or to remove the unwanted ones one by one. Usually the user would remove all
cookies because of the sheer volume of the number of cookies and losing the
"good" cookies is an acceptable comprimise. (The "good" cookies or the "wanted"
cookies usually consist of website login persistence (e.g., hotmail) and website
preferences (eg., Google search preferences))

Problem:
It would be nice to be able to specify which cookies you do not want to remove
on a purge.

Suggestion:
There is already a mechanism to specify which domains you would like to allow
cookies from. i.e., "Tools" -> "Cookie Manager" -> "Unblock Cookies from this
Site". This list reflects the sites you like or trust. But when purging all
cookies using the "Remove All Cookies" button, even the cookies from these
domains are removed.

Therefore I suggest a third button on the Cookie Manager Window that says
something like, "Remove All But Unblocked Cookies", which removes all cookies
except those that were "Unblocked".

This way a user can visit the Hotmail site and specify that it be unblocked and
later when the user cleans out all the cookies, they can keep the Hotmail ones
easily.

This mechanism should not interfere with the website's ability to add and remove
the cookies.

Work Arounds:
The user can always unblock wanted cookies and block all others. But usually
blocking all other cookies cause navigation problems for sites which require
cookies.

Reproducible: Always

Steps to Reproduce:

Comment 1

14 years ago
you can do this with whitelisting - just whitelist the sites you want cookies to
be persistent for, and disable cookies for other sites. (yes, we are working on
making the UI so that you can disable _persistent_ cookies for other sites, i.e.
only allow them for the session). this feature would make your suggestion redundant.

so, i'll dupe this to the appropriate backend bug (UI is bug 216743).

*** This bug has been marked as a duplicate of 217286 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.