If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

bad cpu usage and severe lockup - cumulative in terms of hours

RESOLVED WORKSFORME

Status

()

Firefox
General
--
critical
RESOLVED WORKSFORME
14 years ago
14 years ago

People

(Reporter: jmw, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6a) Gecko/20031001 Firebird/0.7+
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6a) Gecko/20031001 Firebird/0.7+

After between 2.5 and four hours at most of using Mozilla Firebird in
Linux(actively using, loading pages etc.) my cpu usage goes to 99% and  Firebird
becomes unusable (pages take 15 minutes or more to load, buttons become
unresponsive, even closing firebird by clicking the 'x' becomes difficult).This
occurs in both 6.1 and the 7.0+ cvs I downloaded last night. This may in fact be
a Mozilla problem but if it is I haven't noticed because Mozilla crashes and
burns with exit long before this happens. 

Reproducible: Always

Steps to Reproduce:
1.Set up some means of monitoring cpu usage (top, gkrellm, etc.)
2.Start Mozilla Firebird in Linux
3.Use actively for several hours

Actual Results:  
Firebird becomes completely unresponsive.

Expected Results:  
Should have stayed kicking.

Comment 1

14 years ago
I see the same thing on a regular basis.  It is not page-specific;  after continued
use, Firebird starts eating an entire CPU (I am running a dual-processor machine)
and becomes extremely slow, though it does still respond.  I will attempt to also
monitor memory usage in the future and report it here.

Machine specs: 
dual Athlon MP, Redhat 9, 
MozillaFirebird-0.7-i686-linux-gtk2+xft build.

Comment 2

14 years ago
I see this in Firefox 0.8 on Linux (Gentoo). Any debug ideas I should try?

Comment 3

14 years ago
I experience the exact same behaviour with Mozilla 1.5 and 1.6 (Linux i686), so
this problem might not be unique to Firefox.  As with the OP, the behaviour is
always reproducible; it's simply a question of actively using the browser for
long enough.

Comment 4

14 years ago
I'm unable to reproduce with firefox 20040429 linux build.  Without specific
steps to trigger this problem or some debug information about what's actually
going on, this bug isn't of much value.  Please reopen if you can provide that
kind of information. 
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME

Comment 5

14 years ago
Asa, there are no known specific steps to trigger this behaviour besides
relatively intensive browser usage for a few hours.  As for debugging
information, if you indicate what it is you're interested in and how I can get
you the information, I'd be happy to provide it.  I'm currently using Mozilla
1.7b which has the Debug menu, so if you let me know what commands I should
access I'll send you the output.  (Well, in two weeks, actually -- my vacation
starts tomorrow.)
You need to log in before you can comment on or make changes to this bug.