IMAP loads Attachments immediality, BUT loads it a second time when saving

RESOLVED WORKSFORME

Status

MailNews Core
Networking: IMAP
RESOLVED WORKSFORME
14 years ago
9 years ago

People

(Reporter: Oli Kurt, Assigned: Bienvenu)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de-AT; rv:1.4) Gecko/20030624
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de-AT; rv:1.4) Gecko/20030624

When I want to read a IMAP mail, mozilla loads the whole body, including all
attachments.

That is not bad, but when I click on "Save Attachment", then the Attachment is
downloaded a second time.

Reproducible: Always

Steps to Reproduce:
1.Use a slow connection
2.Send you an email with a large attachment
3 [review].Klick an the mail to receive it, see the download progress
4.When the mail is downloaded, click on "save attachment" and see the download
progess a second time

Comment 1

14 years ago
your build is too old.
Please try again with 1.5RC2

this is a WFM.
(Assignee)

Comment 2

14 years ago
actually, I think this is a dup. Your attachment is inline?
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 3

14 years ago
I checked the bug again with V 1.5 final and I the bug is still there.

Furthermore the bug appears in non inline attachments.

The problem can be easily verified with a slow connection and a large attachment.
(Assignee)

Comment 4

14 years ago
try this in 1.7a - I really did fix this in that
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.