All users were logged out of Bugzilla on October 13th, 2018

Crash if making about-to-be-focused form element invisible [@HandleEventInternal]

RESOLVED DUPLICATE of bug 212338

Status

()

--
critical
RESOLVED DUPLICATE of bug 212338
15 years ago
15 years ago

People

(Reporter: joeh, Unassigned)

Tracking

({crash, testcase})

Trunk
x86
All
crash, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

Attachments

(2 attachments)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6a) Gecko/20031002
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6a) Gecko/20031002

When tabbing to a form control, if that control becomes invisible due to the
"onblur" of the previously focused control, Mozilla crashes.

Tested on Windows/Linux 1.4 release, and build 2003100204.

Reproducible: Always

Steps to Reproduce:
1. Load testcase
2. Focus the first input
3. Press tab

Actual Results:  
Mozilla crashes

Expected Results:  
Not crashed.  Focus would ideally go to the next visible control, otherwise
focus should be lost until hitting tab again (which should go to the next
visible control as it does in IE).

The company I work for is developing an application which exhibits this problem.
(Reporter)

Comment 1

15 years ago
Created attachment 132573 [details]
Test case

Comment 2

15 years ago
Confirming bug, 2003-10-02-05 trunk Linux.
Severity: normal → critical
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: crash, testcase
Summary: Crash if making about-to-be-focused form element invisible → Crash if making about-to-be-focused form element invisible [@HandleEventInternal]

Comment 3

15 years ago
Created attachment 132575 [details]
Crash stack on Linux

Comment 4

15 years ago

*** This bug has been marked as a duplicate of 212338 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Crash Signature: [@HandleEventInternal]
You need to log in before you can comment on or make changes to this bug.