Closed Bug 221170 Opened 17 years ago Closed 17 years ago

Custom mail notification sound does not work

Categories

(Thunderbird :: Preferences, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird0.6

People

(Reporter: dude, Assigned: mscott)

Details

User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-us) AppleWebKit/85 (KHTML, like Gecko) Safari/85
Build Identifier: 

When selecting custom .wav sound and selecting a .wav sound, the default system sound still 
sounds when receiving mail.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
Same problem on Windows XP, using build 20031126.
OS: MacOS X → All
Hardware: Macintosh → All
Most probalbly it's an old bug,from mozilla (1.1).
Little workaround:
Browse with mozilla direktly to the file:
On Windows you might get an address like:
file:///c:%5CWINDOWS%5CMEDIA%5C_mail.wav  or
file://c:\WINDOWS\MEDIA\_mail.wav in both cases you have to change each "%5C"
and "\" to "/" so that it will look like:
file:///c:/WINDOWS/MEDIA/_mail.wav 
Should work on most OS'es....
The problem is: the "Browse"-Button gets dir- & file- info from the OS, but uses
internally the latter writing.
Hopefully it will be fixed in future, it might be annoying to "normal" users...
This feature works in the OS/2 ports (1.5 and 1.6b).
This is still not working with Mozilla 1.6 (Win 98/2).
(In reply to comment #2)

First, I'm seeing the problem with Release 1.6 and OSX 10.3.2.

I've tried the workaround on the Mac, and I've tried numerous varieties of file
 name and URL, but was not able to find one that worked.  If there's a
workaround I couldn't find it.
This is fixed in the latest nightlies. 
Status: NEW → RESOLVED
Closed: 17 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird0.6
You need to log in before you can comment on or make changes to this bug.