news.com in 'most popular headlines' section some links are not working

RESOLVED DUPLICATE of bug 191830

Status

SeaMonkey
General
RESOLVED DUPLICATE of bug 191830
15 years ago
13 years ago

People

(Reporter: Ahmet A. Akin, Unassigned)

Tracking

({testcase})

Trunk
x86
Windows XP
testcase

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(4 attachments)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20030925 Firebird/0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20030925 Firebird/0.7

In news.com (or news.com.com), down the page there is a section called 'Most
Popular Headlines' There are several news headlines as links. But strangely for
first 3-4 link mouse over and click does not work. Looks like a javascript problem. 

Reproducible: Always

Steps to Reproduce:
1. Go to news.com
2. Find Most Popular Headlines section down the page
3. Try to move mouse over the headlines. First column 3 or 4 links does not work.

Actual Results:  
Mouse over and click does not work on some links.

Expected Results:  
it should work as the others.
(Reporter)

Updated

15 years ago
Summary: [news.com] → news.com in 'most popular headlines' section some links are not working

Comment 1

15 years ago
Also seen on Mozilla: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.5) Gecko/20030925

Possibly a dupe of 
Bug 196249 hover effect intermittent at tigerdirect.com (categories on left-hand
side)

Comment 2

15 years ago
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.6a) Gecko/20031004

There are tons of whitespace in the source code.
the four not-showing and not-working links are looking the same as the fith
working link:

edited from the source:
<!--  Most Popular Headlines -->
<div id="mostPopular">
<center><img src="original_files/hd_pophdln.gif" alt="Most popular headlines"
width="183" height="20" border="0"></center>

<div id="popleft">
<a onclick="addMyStory('5085251','/2100-1002-5085251.html','Microsoft moves
beyond patches')" href="javascript:void(0)"><img id="add5085251" width="12"
height="8" src="original_files/save_icon.gif"></a>
<a href="http://news.com.com/2100-1002_3-5085251.html?tag=nefd_pop">Microsoft
moves beyond patches</a>

is not working ... and the next is a working one:
	<br>
<a onclick="addMyStory('5085423','/2008-7351-5085423.html','Riding the next
technology wave')" href="javascript:void(0)"><img id="add5085423" width="12"
height="8" src="original_files/save_icon.gif"></a>
<a href="http://news.com.com/2008-7351_3-5085423.html?tag=nefd_pop">Riding the
next technology wave</a>
</div>

The links from below 'More News From Around The Web'
are not underlined, but showing in the statusbar, when hovered.

This looks like Bug 217621, which got duped to Bug 196249.
Bug 217621 Most links behave correctly when hovered, yet some do not show the
underline (as specified in the style sheet).

Comment 3

15 years ago
Created attachment 132653 [details]
10 kb screenshot Mozilla 2003100404

This screenshot shows the intresting region. The only working link in the first
column is highlighted, the mousepointer didn´t get to the screenshot.
The links above that link are neither working nor underlined, when hovered with
the mouse.

Comment 4

15 years ago
Created attachment 132654 [details]
10 kb screenshot Opera 7.20 showing misrendering.

Opera 7.20 Version 3087 shows the 5 links of the second column rendered above
the first 5 LINES of the first column, so only the first 3 links are
unreadable.
Is there a problem with the HTML/CSS on this site, or is this just an Opera
bug,
different from the Mozillabug seen on this site?

Comment 5

15 years ago
Created attachment 132724 [details]
2kb testcase style included

Hover over the links, the first 4 don´t work.
Change id of div id="popright to maybe _popright, and it works.

Comment 6

15 years ago
Created attachment 132727 [details]
minimal testcase

2kb testcase was made from the original files, 
this one here I changed the style until I could show the bug.
hover over the links to test.

#popleft {
position: relative;
float: left;
width: 205px;

}

 #popright {
position: relative;
/* float: left; */
}

If you uncomment the last comment, it works.

Updated

15 years ago
Keywords: testcase
(Reporter)

Comment 7

15 years ago
i dont know what has changed but news.com is working correctly right now.

Comment 8

15 years ago
> i dont know what has changed but news.com is working correctly right now.

Doesn´t matter, the testcase still shows the bug, and that can happen again.
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.6a) Gecko/20031008

Updated

15 years ago
Depends on: 178828

Comment 9

15 years ago
If you delete DIV#popright{position:relative} it will render correctly.
dupe of bug 198063.

Comment 10

14 years ago
the dependency should be the other way around: bug 178828 depends on this one;

Comment 11

14 years ago

*** This bug has been marked as a duplicate of 191830 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Actually, this is a dup of bug 198063 which is now invalid per the z-ordering
rules in CSS2.1.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.