Content portion of frameset is not displayed

VERIFIED INVALID

Status

()

Core
Layout: HTML Frames
VERIFIED INVALID
14 years ago
14 years ago

People

(Reporter: BARRANCO christian, Unassigned)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; fr; rv:1.5a) Gecko/20030728 Mozilla Firebird/0.6.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; fr; rv:1.5a) Gecko/20030728 Mozilla Firebird/0.6.1

The fisrt welcome page of the URL is shown but not the next one. All the pages
has been created with Ulead Photo Impact8. I have the source code if you wish.

Reproducible: Always

Steps to Reproduce:
1. Clic on Brothers 2003 banner
2.
3.

Actual Results:  
You reach a blank page instead of the pictures.

Expected Results:  
To show thumb pictures.

Comment 1

14 years ago
Created attachment 132636 [details]
testcase

Testcase, slightly reduced

Comment 2

14 years ago
Created attachment 132637 [details]
testcase

testcase, slightly correctly to render

Comment 3

14 years ago
In the first testcase (which just throws away the outermost FRAMESET since it
doesn't affect the display whether it's there or not), it looks to me like
you've assigned 100% of the width of the outer FRAMESET to the "null" frame.  So
the frame with content has nowhere to render.

The second testcase changes the outer FRAMESET to 0, * for width.  Now the
content renders.

This is not a Firebird-specific bug, as Mozilla gives the same rendering.
->Layout/Frames, though I'm not convinced there's any bug at all.
And I really don't get why, if there's one page of content, there's any need to
wrap it in all these null frames/framesets.
Assignee: blake → frame
Component: General → Layout: HTML Frames
Product: Firebird → Browser
QA Contact: madhur
Summary: Impossible to adress the second page of the URL → Content portion of frameset is not displayed
Version: unspecified → Trunk
Indeed.  It looks like the page is missing some </frameset> tags... and since
<frameset> can contain another <frameset> our behavior here is correct.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
(Reporter)

Comment 5

14 years ago
I don't know whether or not it's a bug but IE6 well manages all the pages.
One more comment :  all pages have been built automaticaly by PhotoImpact 8.
Summary: Content portion of frameset is not displayed → Additional comments : bug or not ?

Comment 6

14 years ago
IE is rather infamous for forgiving a lot of invalid code.

You might want to use another tool to create the code, or hand-code it.
Status: RESOLVED → VERIFIED
Summary: Additional comments : bug or not ? → Content portion of frameset is not displayed
It's not a matter of "forgiving".  It's just a matter of IE not rendering
framesets correctly that Mozilla gets right...  The tool in question is clearly
pandering to IE's bug in this case, but that does not mean that Mozilla should
introduce the same bug....
(Reporter)

Comment 8

14 years ago
I agree with all of you. But, as PhotoImpact8 might be worlwide used to share
pictures on the web, a communty might not be able to use Mozilla for that. How
could we advise Ulead to change his way to create web pages ? 
By having people who actually use the product contact the company that sold them
defective software and ask that it be fixed.
You need to log in before you can comment on or make changes to this bug.