Thunderbird doesn't apply filters to folders when clicking "Run Now"

RESOLVED WORKSFORME

Status

Thunderbird
Preferences
RESOLVED WORKSFORME
14 years ago
10 years ago

People

(Reporter: Johannes Bauer, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5a) Gecko/20030728 Mozilla Firebird/0.6.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5a) Gecko/20030728 Mozilla Firebird/0.6.1

When filters have already been defined and they should be applied to an existing
mail folder, Thunderbird simply does nothing when more than one filter is
seleceted (this is in the "Message Filters" dialog box). When only one filter
has been selected and the "Run now" button is pressed the filter is processed
just fine. Yet it is kind of annoying to select each rule and press the "Run
now" button - especially when you have 250+ filters. Also the menu item "Tools",
"Run filters on folder" does not seem to have any effect.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Comment 1

14 years ago
The bug is still present in Thunderbird version 0.7.3 (20040803)

Does anybody know when it could be resolved?

Thanks

Comment 2

13 years ago
This is not fixed in 1PR, or at least the part where "Run filters on folders"
isn't.  This on Linux.  Apparently it works (haven't tested it, but from reports
in forum) on anything but the global inbox and sub folders.  Hum, it needs to
work in the global folders as well.

Comment 3

13 years ago
I've been banging my head on my desk trying to figure out why my filters weren't
working for mail that had been sorted into a catch-all directory that I now
wanted to sort again into subdirectories.

Then I saw "For incoming messages that:" in the Filter Rules dialog.  Is there
no way to filter existing mail?  What is the point of Tools > Run Filters on
Folder?  There is a contradiction.

Also, it doesn't seem to matter whether I have 1 or all filters checked.  I'm
using TB 0.8.

Comment 4

13 years ago
Verified as broken in 0.9; WFM in Thunderbird 1.0.  Looks like the good folks on
the Thunderbird team have been busy... good job guys.

Comment 5

13 years ago
thx - this is a dup, but marking wfm.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.