[permmgr] js error in chrome://navigator/content/navigator.js

VERIFIED FIXED

Status

()

VERIFIED FIXED
15 years ago
14 years ago

People

(Reporter: dwitte, Assigned: mvl)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
saw this while hacking around on cookiemgr today:

Error: popupManager.getEnumerator is not a function
Source File: chrome://navigator/content/navigator.js
Line: 172

looks like there's no getEnumerator method on nsIPopupWindowManager... mvl, is
this you?
(Assignee)

Comment 1

15 years ago
I guess this is for firebird.
popupManager needs to be permissionManager. I'm not sure why the enumarator is
used. It seems to me that testPermission would work too, but i need to double
check that.
(Reporter)

Comment 2

15 years ago
firebird? no, i saw this on seamonkey.

please fix :)
(Assignee)

Comment 3

15 years ago
Created attachment 133572 [details] [diff] [review]
patch v1

The popupwindowmanager enumerator is gone, the permission manager should be
used instead.
(Assignee)

Comment 4

15 years ago
Comment on attachment 133572 [details] [diff] [review]
patch v1

on irc: <dwitte_z> r=me

bryner, can you sr?
Attachment #133572 - Flags: superreview?(bryner)
Attachment #133572 - Flags: review+
Attachment #133572 - Flags: superreview?(bryner) → superreview+
(Assignee)

Comment 5

15 years ago
checked in
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
Blocks: 200305
(Assignee)

Comment 7

14 years ago
*** Bug 200305 has been marked as a duplicate of this bug. ***
No longer blocks: 200305
You need to log in before you can comment on or make changes to this bug.