Adress card isn't copied if there's no eMail-Entry entered

RESOLVED DUPLICATE of bug 133586

Status

SeaMonkey
MailNews: Address Book & Contacts
--
major
RESOLVED DUPLICATE of bug 133586
14 years ago
13 years ago

People

(Reporter: Christian Schneider, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; WinNT4.0; de-AT; rv:1.4) Gecko/20030624
Build Identifier: Mozilla/5.0 (Windows; U; WinNT4.0; de-AT; rv:1.4) Gecko/20030624

If you choose a card which has no eMail-entry and you drag it to a given
adresslist the card isn't copied without any message of the reason. So you
begin to search about the reason.


Reproducible: Always

Steps to Reproduce:
1. Chose a card without eMail-entry
2. Drag it to an adresslist
3. You see no copy, no message
4. Enter an eMail-adress for this card
5. Repeat the same drag
6. The copy works!


Expected Results:  
I propose to change the behavior in either to generate a message to inform
the user that this action isn't possible because of no valid mailadress or
to allow the copy.

Comment 1

14 years ago
Confirming on winxp, 1.6b.  Various effects I've noticed include:
1. On creating an empty mailing list, drag one such card succeeds, but also
duplicates itself in the addressbook.
2. In same mailing list, dragging another such card fails silently.
3. At least once after dragging several email-less cards, dragging a card with
email address failed.
4. An empty card once appeared in the mailing list after failing silently with a
card earlier.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

14 years ago
This is probably a dupe of bug 220401.  Also, possibly related: bug 216114

Comment 3

14 years ago

*** This bug has been marked as a duplicate of 133586 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.