dell.co.uk: "Parts for My Dell" page does not work

VERIFIED WORKSFORME

Status

Tech Evangelism Graveyard
English Other
VERIFIED WORKSFORME
15 years ago
3 years ago

People

(Reporter: Tom Cumming, Unassigned)

Tracking

unspecified
x86
Windows XP

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.5) Gecko/20030925
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.5) Gecko/20030925

When the "step 1" box is completed, the "step 2" box does not automatically
appear as it should.

Reproducible: Always

Steps to Reproduce:
1. Goto http://dellware.euro.dell.com/dellstore/DellKits/default.asp?s=uktra in
Mozilla
2. Select any system type from the "step 1" drop-down list.

Actual Results:  
Nothing.

Expected Results:  
Displayed a second drop down list underneath the first one, allowing the
selection of a system model number. Then when this is selected, a "search"
button should appear underneath that.

Comment 1

15 years ago
Error: frmDellKits is not defined
Source File: http://dellware.euro.dell.com/dellstore/DellKits/default.asp?s=uktra
Line: 25

function brandChange()
{
	document.frmDellKits.BrandSelected.value = "Y";
	frmDellKits.submit();
}

frmDellKits.submit() is an invalid syntax that IE accepts for whatever reason. 
Confirming new.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: evang500
(Reporter)

Comment 2

15 years ago
I have just looked all over the site for a relevant email address to contact,
and the best I could find was the web form at
<http://support.euro.dell.com/uk/en/EmailDell/EmailWebmaster.asp>. It does say
it is supposed to be only for feedback of the support.dell.com pages, and says I
should not expect to get a reply, so I'm not holding my breath, but I cannot
find any other contact details that look any more relevant.

Comment 3

14 years ago
contacted.
Status: NEW → ASSIGNED
Target Milestone: --- → Jun
couldn't dinf a "step one" link as indicated in comment #1, site looks ok to me
-> WFM
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 5

14 years ago
Agreed - the site has been changed around a bit since i filed the bug -
equivilant page is now:
http://accessories.euro.dell.com/sna/dellitems.aspx?c=uk&l=en&s=dhs&cs=ukdhs1&~ck=mn

and appears to be working fine.
Status: RESOLVED → VERIFIED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.