Closed Bug 221294 Opened 18 years ago Closed 18 years ago

Choosing seating at the Chicago Symphony (cso.org) site broken

Categories

(Tech Evangelism Graveyard :: English US, defect)

x86
Linux
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 212798

People

(Reporter: stephen, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030923
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030923

The CSO page for choosing seating for a concert doesn't work (works in konqueror). 

When you go to a page for a performance, there is a diagram of the seating on
the hall. Choosing a seating location should tell you the price for that
location, but it looks as though the web server is not being notified of mouse
clicks on the locations. Mouse overs on the image do work, but mouse clicks don't.

Reproducible: Always

Steps to Reproduce:
1. Go to CSO.org.
2. Select a concert.
3. At bottom of page choose "CHOOSE SEAT AND COST"
4. Click in a range of seats on the image.

Actual Results:  
Nothing.

Expected Results:  
Gives you a price for a ticket in this location (works in konqueror).
Error: plugin.SetWindow is not a function
Source File: javascript: function jsScriptObject(obj) { this.wrappedJSObject =
obj; } jsScriptObject.prototype = { evaluate : function(expression) { return new
jsScriptObject(eval(expression)); } }; var plugin =
document.embeds['csoseating']; plugin.SetWindow(new
jsScriptObject(window),226366177);
Line: 1
OS: Linux → All
Moving to Tech Evangelism
Assignee: general → english-us
Status: UNCONFIRMED → NEW
Component: Browser-General → English US
Ever confirmed: true
Product: Browser → Tech Evangelism
QA Contact: general → english-us
Version: Trunk → unspecified
I just tried this out on windows (Mozilla/5.0 (Windows; U; Windows NT 5.0;
en-US; rv:1.4) Gecko/20030624) and the issue isn't present here -- just on the
linux build.
they assume that if you have flash it is scriptable however mozilla on linux
broke flash scripting when they moved to gcc 3.2.3 for legal reasons. duping
against bug 212798. 

*** This bug has been marked as a duplicate of 212798 ***
Status: NEW → RESOLVED
Closed: 18 years ago
OS: All → Linux
Resolution: --- → DUPLICATE
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.