{inc}text over floated div when unsized image not in cache

RESOLVED WORKSFORME

Status

()

Core
Layout: Floats
RESOLVED WORKSFORME
15 years ago
13 years ago

People

(Reporter: Robert Vollmert, Unassigned)

Tracking

({qawanted, testcase})

Trunk
x86
Linux
qawanted, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5a) Gecko/20030918 Mozilla Firebird/0.6.1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5a) Gecko/20030918 Mozilla Firebird/0.6.1

In the attached HTML page, text is written over the floated div if the (not
explicitly sized) image is not in the browser's cache. After reloading, the page
displays correctly. This can also be seen with an image instead of a div at
http://www.fu-mathe-team.de/, where the bug was discovered.

Reproducible: Always

Steps to Reproduce:
1. clear browser cache
2. load the page

Actual Results:  
"text" is displayed over the red box.

Expected Results:  
"text" should be displayed to the right of the red box.

I've also confirmed this on

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030908 Debian/1.4-4
(Reporter)

Comment 1

15 years ago
Created attachment 132695 [details]
page that exhibits the bug
(Reporter)

Comment 2

15 years ago
http://www.fu-mathe-team.de/ doesn't show this anymore as the image size is now
specified.

Is the redrawing of the page after the image loads what is known as "reflow"?
Thought I'd add the word to a comment so it shows up in searches.
Happens with a current trunk build too...  I suspect this is a duplicate, though.
Keywords: qawanted

Updated

15 years ago
Summary: text over floated div when unsized image not in cache → {inc}text over floated div when unsized image not in cache
(Reporter)

Comment 4

15 years ago
Quite possibly a duplicate, since I didn't really know what to search for.

It does seem a little obscure, though: it doesn't happen when the heading is
removed.
(Reporter)

Comment 5

15 years ago
Bug 175364 seems related, though I can't say whether it's a duplicate.
(Reporter)

Comment 6

15 years ago
Created attachment 132699 [details]
revised testcase based on that for bug #175364

This works without images, now.

Updated

14 years ago
Keywords: testcase

Comment 7

14 years ago
I've got the same problem with a site I'm writing on which I can't size the image explicitly because it's 
stored on a mysql database.

A solution to this bug would be to wait for everything to be loaded on the page before applying the 
style and scrolling the page to the eventually specified anchor (there's also a problem with that). KHTML 
actualy handles this issue that way, and it renders properly such things.

You can also set the Hardware and OS to All, since this bug showed up also on Mac OS X and Windows.

Comment 8

13 years ago
I've tested this on a current trunk build and is not able to reproduce the
problem with the attached testcase any longer. Any thoughts from the reporter,
otherwise this could be closed.

Comment 9

13 years ago
Still not able to reproduce on current trunk, and no comments from reporter for
over a month. Setting as WFM, reopen if that is wrong. 

Bug 299367 contains a list of bugs with similar summaries and their status.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.