When page sent as application/xhtml+xml mozilla does not remember form contents on refresh or back/forward

RESOLVED DUPLICATE of bug 176477

Status

()

Toolkit
Form Manager
RESOLVED DUPLICATE of bug 176477
14 years ago
10 years ago

People

(Reporter: Hadley Wickham, Assigned: dveditz)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5a) Gecko/20030728 Mozilla Firebird/0.6.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5a) Gecko/20030728 Mozilla Firebird/0.6.1

Usually when you enter data into a form, Mozilla remembers this data if you
refresh the page or move away from the page and return.  However, when the page
is sent as application/xhtml+xml this behaviour does not occur.

Reproducible: Always

Steps to Reproduce:
1.  Go to http://ineffable.co.nz/bugs/form-xhtml.html
2.  Type testing in the text box
3.  Press refresh, text vanishes.

Compare to 

1.  Go to http://ineffable.co.nz/bugs/form-html.html (content-type: text/html)
2.  Type testing in the text box
3.  Press refresh, text stays.
Actual Results:  
Text vanishes.

Expected Results:  
Text should remain.
(Reporter)

Comment 1

14 years ago
Oooops, I meant to do the test in the latest build of Mozilla (Mozilla/5.0
(Windows; U; Windows NT 5.0; en-US; rv:1.6a) Gecko/20031004) not Firebird, but
exactly the same thing happens.
Whiteboard: DUPEME

Comment 2

14 years ago
*** This bug has been marked as a duplicate of 176477 ***

*** This bug has been marked as a duplicate of 176477 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Whiteboard: DUPEME

Updated

10 years ago
Component: Form Manager → Form Manager
Product: Core → Toolkit
QA Contact: tpreston → form.manager
You need to log in before you can comment on or make changes to this bug.