dabs.com - Drop down menus not displayed

RESOLVED FIXED

Status

Tech Evangelism Graveyard
English US
RESOLVED FIXED
15 years ago
3 years ago

People

(Reporter: David Bridson, Unassigned)

Tracking

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5a) Gecko/20030718
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5a) Gecko/20030718

Moving the mouse over the tabs near the top of the page brings up a popup menu
listing product types in Internet Explorer. Mozilla doesn't show the popup menu.

Reproducible: Always

Steps to Reproduce:
1. Visit page
2. Move mouse over one of the tabs near the top of the page

Actual Results:  
Popup menus fail to display

Expected Results:  
Displayed the popup menus.

Comment 1

15 years ago
Drop down menus displayed by javascript:
<script language="javascript" src="/uk/clientCode/Navigation/ie6DropDownNav.js">

This would seem to be a case for Tech Evangelism.



Summary: Page's popup menus to not work at all → Drop down menus not displayed on http://www.dabs.com/

Comment 2

15 years ago
Created attachment 132856 [details]
js for dropdown menus

Despite the ominous file name, I don't know for certain whether it is IE
specific code.

Comment 3

15 years ago
After writing to Dabs they replied with a link to
http://www.dabs.com/uk/help/usingourwebsite/uw_mozilla.htm which says that they
are trying to fix the problems now. I did tell them of the problem with the
product details/features/etc. not showing, and actually gave them some code to
fix it (they're using document.[ID] rather than document.getElementById([ID])
but I doubt they passed it on to their tech dept.

Also I notice with their site that the vertical scrollbars don't work properly
when the images are still loading (mainly on the compare products dialog) but
I'm sure that must be another bug and not specific to their site only.

Comment 4

15 years ago
Well Dabs have fixed the descriptions not showing, so it looks like our
complaints didn't fall on deaf ears after all! I think they'll probably fix the
menus in Mozilla soon, and this bug can probably be marked won't fix/Tech
Evangelism or whatever. Also the line <script language="javascript"
src="/uk/clientCode/Navigation/ie6DropDownNav.js"> in the code only seems to
appear if IE is used, so it's obviously not Mozilla's fault.

Comment 5

15 years ago
Not sure if this is related, but I'm also finding that when searching only a few
search results are displayed, and not the complete page.

Example URL:
http://www.dabs.com/uk/search.htm?searchPhrase=dsl%20modem

Works in IE every time.

Comment 6

15 years ago
Yeah that's the scrollbar bug I was talking about earlier. It seems to happen
when there are image place holders rendered before the images are downloaded.
Then once the images finish downloading and are rendered the scrollbar doesn't
take account of that. If you resize the browser it fixes it.

Comment 7

15 years ago
See bug 222840 for the scrollbar problem.

Comment 8

15 years ago
The menu code uses document.all, which is a sure sign of IE specific code.
Sending to Tech Evangelism based on this and the other comments in the bug.
Thanks for spreading the word, Rick!
Assignee: other → english-us
Status: UNCONFIRMED → NEW
Component: Layout → English US
Ever confirmed: true
Product: Browser → Tech Evangelism
QA Contact: ian → english-us
Version: Trunk → unspecified

Comment 9

15 years ago
Rick, please keep up the good work and forward any problems you have to their
web team. Please ask them to contact us if they need any help.
Summary: Drop down menus not displayed on http://www.dabs.com/ → dabs.com - Drop down menus not displayed

Comment 10

15 years ago
The menus now work on Dabs' site so I think this can be marked as fixed. We'll
have to all put some business Dabs' way for caring about Mozilla ;)

Comment 11

15 years ago
http://www.dabs.com/uk/home.html is showing the drop down menus.
http://www.dabs.com/uk/channels/components/harddiskdrives/internalide35/products.htm?catid=202
menus are also working, URL from Bug 221355
Product list is either incomplete or missing on Mozilla, works in Internet Explorer.

marking fixed, so they can concentrate on bug 221355
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED

Comment 12

14 years ago
Unfortunately, there are still major problems viewing dabs.com's new website
with Mozilla-based browsers, causing me to resort to using Internet Explorer
when viewing their website, and I've submitted a new bug report covering one of
them in bug #243404.  CC yourself there if you're interested in helping sort
this out.
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.