Some text hyperlink hotspots out-of-whack

VERIFIED DUPLICATE of bug 21678

Status

()

Core
Layout
P3
major
VERIFIED DUPLICATE of bug 21678
18 years ago
15 years ago

People

(Reporter: Stephen Anderson, Assigned: joki (gone))

Tracking

Trunk
x86
Windows 95
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [TESTCASE], URL)

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
I am using build 1999121712 on Win95 OSR2.

I was just browsing a CNN story (which I pulled and saved as URL) when I
noticed that some of the hotspots on the text hyperlinks are really screwed up -
some so screwed up they are not hyperlinks anymore.

If you'll go to the page pointed to by the URL and look down the right hand
side of the article, you'll see CNN has provided several uhh.. boxes with
additional stuff pertaining to the article.  The hotspot malfuncitons seem to
be confined to these right hand side boxes.

For instance, find the box titled Resources.  Inside there is a poll pertaining
to the article. Peruse the "View Results" hyperlink with your mouse cursor.
Mine shows that only the one pixel high line the underlines the words is a
hotspot, not the words themselves.  In the next two boxes below Resources,
"Message Board" and "Also" neither of the two hyperlinks in those boxes display
any hyperlink behaviour at all.

Higher up in the page, in the "Video" box you will see an odd mix of
behaviour.  The Quicktime "Play" link seems to only have a hotspot on its
underline.  The two Real "28K" and "80K" links appear to have normal hyperlink
hotspots over all the link.  Then just below the Windows Media "28K" and "80K"
hyperlinks don't have any hotspots at all.

I'm going to try and boil this page down to a simple testcase, but I've got a
good bit on my plate right now so I don't know how soon that will be.
(Reporter)

Comment 1

18 years ago
Created attachment 3623 [details]
Testcase (simple?)
(Reporter)

Updated

18 years ago
Assignee: nobody → troy
Component: Browser-General → Layout
(Reporter)

Comment 2

18 years ago
I've attached a simple (use that term loosely) testcase and changed the
component to Layout because of the odd behaviour I see in manipulating the
testcase.

Basically I've left the structure of the original CNN page the same, just
chopped out a lot of tables and some content inside the table cells that I
left.  First before I get flamed for calling the testcase simple, let me say
that deleting more of the original content does not make the bug go away, but
it does alter its behaviour. So... I left it for the boys that know more than I
to play with.

Anyway, if you look at the testcase, I think you'll see the exact behaviour
with the hotspots as described for the URL document.  If however you start
deleting more of the "story" content, the text that runs down the left side of
the boxes doesn't quite run the length of the boxes anymore.  When that
happens, the location and size of the hotspots for the hyperlinks in the boxes
on the right side change.  In one permutation I actually had hotspots showing
up between the lines of actual hyperlinks.   Since the hotspots were hoping
around depending on the layout of the text to its left, I decided this is
probably a good problem for the Layout component dept.
(Reporter)

Updated

18 years ago
Whiteboard: [TESTCASE]

Updated

18 years ago
Assignee: troy → joki

Comment 3

18 years ago
Looks event related
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
This is just a right floating block which is not getting events because it has
a normal-flow block above it.

Looks like a dup of bug 1413 or bug 21678. Marking as dup of 21678.

*** This bug has been marked as a duplicate of 21678 ***

Comment 5

18 years ago
VERIFY duplicate
Status: RESOLVED → VERIFIED

Comment 6

15 years ago
Spam for bug 129472
QA Contact: nobody → nobody
You need to log in before you can comment on or make changes to this bug.