Get rid of most of the stuff in mozilla/l10n

VERIFIED FIXED

Status

()

Core
Localization
VERIFIED FIXED
15 years ago
11 years ago

People

(Reporter: sipaq, Assigned: rchen)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
Browsing through mozilla/l10n shows a lot of probably unused stuff.

- mozilla/l10n/lang only contains a danish translation from October 1999
- mozilla/l10n/nscp is netscape-specific stuff which should be removed
- I have no clue what mozilla/l10n/us is about, but the code in there dated back 
  to november 1999 mostly and is probably unused, too.
- mozilla/l10n/langpacks/nscp is netscape-specific stuff again and should be   
  removed. I'm not sure about the rest. If it is unused it should go, if it is 
  still used, it should remain.
(Reporter)

Updated

15 years ago
No longer depends on: 193752
(Reporter)

Comment 1

15 years ago
*** Bug 193752 has been marked as a duplicate of this bug. ***
This belongs in the Localization component
Assignee: smontagu → rchen
Component: Internationalization → Localization

Comment 3

15 years ago
mozilla/l10n/nscp and mozilla/l10n/langpacks/nscp is stuff donated from nscp to
Mozilla, so Mozilla l10n people can use their stuff as well.

Additionally, this bug might relate to bug 179949
(Reporter)

Comment 4

15 years ago
From bug 179949 comment 7:

We had some language translation contribution from Netscape 7.0, you can check
out it by:
   cvs co mozilla/l10n/nscp
and the tagging is NSCP-L10N-1-0-1-RC1.

We didn't check it into the trunk, we think other people may have different
translation, if anybody want to contribute, they can check in their files like:
   mozilla/l10n/yourname

Localizer can pick up any translation they like...

In the trunk "mozilla/l10n/langpacks" directory, the files are too old, and only
few languages there. We need to clean it up.

Comment 5

15 years ago
Bug 193740 removed the timebomb stuff, so we can cvs remove a bunch of
timebomb.dtd and folders:
http://lxr.mozilla.org/mozilla/find?string=timebomb

Comment 6

15 years ago
Removing files from l10n/ has no connection with the timebomb stuff.

Either we cvs remove some subdirectries completely or we don't even touch them.
Even if some localizations might be old, they should still be complete (as in:
complete for the version of Mozilla they were made for).

I still want to get current German l10n work into the Mozilla tree, BTW, this
means I still intend to fix bug 179949 :)
(Reporter)

Comment 7

15 years ago
>Removing files from l10n/ has no connection with the timebomb stuff.

It has a connection in so far, that timebomb stuff is no longer shipped with
mozilla and timebomb.dtd-files aren't needed any longer.

>Either we cvs remove some subdirectries completely or we don't even touch them.
>Even if some localizations might be old, they should still be complete (as in:
>complete for the version of Mozilla they were made for).

If I understand the cvs remove command correctly, removing files from cvs does
not delete the files completely, it only deletes them from the current working
trunk, but they are still accessible on older branches. So when removing these
files, one would still be able to build an older release of Mozilla with these
files. Or am I making a mistake here?

Comment 8

15 years ago
Simon: You're making the mistake that you believe that mozilla/l10n/ directory
contains trunk versions of anything. Actually, no files in there are up to the
trunk, and some (esp. of the nscp files) are only available as real branch files.
Most of the files don't have a branch tag set but are actually only at a trunk
stage (and they don't get pulled by a normal build process anyway).

Comment 9

15 years ago
I've got 718 files in 139 directories worth 800 KB in my tree, checked out with
make (for building Firebird), consisting of mozilla/l10n/langpacks/en-DE and
en-GB. The files are mostly from 2000, some from 2001.

While I don't care about other directories that much, it would be nice if these
two could be removed or moved to a branch, so that they don't get pulled by default.

Comment 10

15 years ago
IMO, mozilla/l10n compeltely shouldn't be pulled by default, but you're right,
the files in that directories should belong to their respective branches, if any.

Comment 11

14 years ago
http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=all&branch=HEAD&branchtype=match&dir=mozilla%2Fl10n&file=&filetype=match&who=&whotype=match&sortby=Date&hours=2&date=all&mindate=&maxdate=&cvsroot=%2Fcvsroot
shows no serious maintenance of these files. In my quest to remove stuff from
the tree that doesn't currently build/work, r=bsmedberg to remove everything in
mozilla/l10n

Comment 12

14 years ago
Benjamin, checkout now displays the following errors:
cvs server: warning: mozilla/l10n/makefile.win is not (any longer) pertinent
cvs server: warning: mozilla/l10n/Makefile.in is not (any longer) pertinent
cvs server: warning: mozilla/l10n/langpacks/makefile.win is not (any longer)
pertinent
cvs server: warning: mozilla/l10n/langpacks/Makefile.in is not (any longer)
pertinent
(Reporter)

Comment 13

14 years ago
This is FIXED since bsmedberg's checkins
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
(Reporter)

Updated

11 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.