Closed Bug 221364 Opened 18 years ago Closed 18 years ago

insertBefore(node, firstChild.nextSibling) not working as it should!?

Categories

(Core :: DOM: Core & HTML, defect)

x86
Windows 2000
defect
Not set
major

Tracking

()

RESOLVED DUPLICATE of bug 26179

People

(Reporter: andreas, Unassigned)

References

()

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; sv-SE; rv:1.5) Gecko/20030925
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; sv-SE; rv:1.5) Gecko/20030925

See URL. The ambition is to insert a row following the first row in a table.

Reproducible: Always

Steps to Reproduce:
1.se URL
2.
3.

Actual Results:  
The row is inserted before firstChild, not before its sibling.

Expected Results:  
Placed the new row after the first one. Leaving Row1 always first!
Same file as the URL (simple HTML and javaScript)
The firstChild of the <tbody> is a textNode.  It's nextSibling is the table row.
 So everything is in fact working correctly...

*** This bug has been marked as a duplicate of 26179 ***
Status: UNCONFIRMED → RESOLVED
Closed: 18 years ago
Resolution: --- → DUPLICATE
Component: DOM: Core → DOM: Core & HTML
QA Contact: ian → general
You need to log in before you can comment on or make changes to this bug.