Sort by "Priority" actually does sort by "Date"

RESOLVED WORKSFORME

Status

SeaMonkey
MailNews: Message Display
RESOLVED WORKSFORME
15 years ago
13 years ago

People

(Reporter: Ian Jeffray, Unassigned)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20030916
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20030916

Using the column headings in the mail window, clicking on "Date" sorts by date,
Sender sorts by sender and soforth.  Clicking on "Priority", however, appears to
sort by date - certainly not priority.


Reproducible: Always

Steps to Reproduce:
1. Receive lots of mail with various priorities set
2. Add "Priority" column to the mail listing view
3. Click on "Priority" column header - observe sort order is NOT priority order

Actual Results:  
Sort order appears to be date order, not priority.


Expected Results:  
Should be sorted by priority
Product: Browser → Seamonkey

Updated

13 years ago
Assignee: sspitzer → mail

Comment 1

13 years ago
I'm unable to reproduce this symptom.  I have a few messages which show Highest 
in the Priority column, a few which display as "Normal" and a bunch which show 
nothing.  The latter two groups are intermingled, sorted according to "order 
received" (which in most cases is the same as Date), but the Highest pri 
messages are all at the top.  "Order Received" is always the secondary criterion 
used to sort messages, so this appears to be working to me.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.