link focus disappears after activation

VERIFIED DUPLICATE of bug 36539

Status

()

enhancement
VERIFIED DUPLICATE of bug 36539
16 years ago
a month ago

People

(Reporter: tyl2, Unassigned)

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5b) Gecko/20030911 Firebird/0.6.1+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5b) Gecko/20030911 Firebird/0.6.1+

First, this problem probably occurs on all builds and platforms. I just don't
have the computers to try it.

When a link is selected and browser loads a new page, then goes back to original
page, the selection or focus disappears.

In MS IE, the focus is still there, allowing the user to tab to the next link.
This is extremely useful on a lot of sites. While Find-As-You-Type makes
keyboard browsing easier, focus retention should not be ignored.

Reproducible: Always

Steps to Reproduce:
It's hard to explain, so please try the steps as you go along.

1. Go to any page with multiple hypertext links.
2. Click or select a link. A dash border appears, indicating the link is
selected. If it's clicked, the browser loads another page.
3. Click [Back] or Alt+Left brings browser back to original page.

Actual Results:  
The border disappears.

Expected Results:  
The border remains on the link that was activated.
(Reporter)

Comment 1

16 years ago

*** This bug has been marked as a duplicate of 36539 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
Component: Event Handling → User events and focus handling
Product: Core → Core
You need to log in before you can comment on or make changes to this bug.