lists from address book don't work: "need user@domain"

RESOLVED EXPIRED

Status

MailNews Core
Composition
--
major
RESOLVED EXPIRED
15 years ago
10 years ago

People

(Reporter: Neal McBurnett, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030625
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030625

Selecting a list as a recipient causes Mozilla 1.4 to fill in an address like

 test list <"description of test list">

and then later to complain that the address "description of test list" needs to
be in "user@domain" format.


Reproducible: Always

Steps to Reproduce:
1. create a mailing list in address book named "test list", with description
"description of test list"
2. compose a message, type "test l" and get autocompletion
3. observe bogus email address <"description of test list"> on To: line
4. hit "send"

 observe pop-up message saying you need to use "user@domain" format

Actual Results:  
no mail sent, just a popup message indicating need for "user@domain" format


Expected Results:  
Send mail properly.


Worked fine in 1.3b and previous versions.
Stopped working after upgrade to 1.4.

Also saw a complaint about "one of your address book files (abook.mab file)
 could not be read.  ...new abook file, backup in abook.mab-1.bak"

But the problem persisted even after removing abook.mab and impab.mab
and entering new list from stratch.

Comment 1

15 years ago
Build 2003101804
XP

Reporter, can you try a newer build.

Worksforme
Product: MailNews → Core
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/
This bug has been automatically resolved after a period of inactivity (see above
comment). If anyone thinks this is incorrect, they should feel free to reopen it.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → EXPIRED
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.